Project

Profile

Help

Issue #8452

Package matching query does not exist when syncing TimeScaleDB repo after migration

Added by iballou 8 months ago. Updated 8 months ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Katello
Sprint:
Sprint 93
Quarter:
Q1-2021

Description

I've found this to be reproducible if you try syncing https://packagecloud.io/timescale/timescaledb/el/7/x86_64 or https://packagecloud.io/timescale/timescaledb/el/8/x86_64 with Pulp 2, migrate, then re-sync. Tested on Katello 3.18.1.

Pulp versions:

pulp-2to3-migration (0.6.0)
pulp-certguard (1.0.3)
pulp-cli (0.7.0)
pulp-container (2.1.0)
pulp-deb (2.7.0)
pulp-file (1.3.0)
pulp-rpm (3.7.0)
pulpcore (3.7.3)
---
pulp_tasks:
- pulp_href: "/pulp/api/v3/tasks/afed94a5-e893-4140-8712-85c248359961/"
  pulp_created: '2021-03-25T15:18:24.485+00:00'
  state: failed
  name: pulp_rpm.app.tasks.synchronizing.synchronize
  started_at: '2021-03-25T15:18:24.611+00:00'
  finished_at: '2021-03-25T15:18:28.367+00:00'
  error:
    traceback: |2
        File "/usr/lib/python3.6/site-packages/rq/worker.py", line 936, in perform_job
          rv = job.perform()
        File "/usr/lib/python3.6/site-packages/rq/job.py", line 684, in perform
          self._result = self._execute()
        File "/usr/lib/python3.6/site-packages/rq/job.py", line 690, in _execute
          return self.func(*self.args, **self.kwargs)
        File "/usr/lib/python3.6/site-packages/pulp_rpm/app/tasks/synchronizing.py", line 266, in synchronize
          dv.create()
        File "/usr/lib/python3.6/site-packages/pulpcore/plugin/stages/declarative_version.py", line 148, in create
          loop.run_until_complete(pipeline)
        File "/usr/lib64/python3.6/asyncio/base_events.py", line 484, in run_until_complete
          return future.result()
        File "/usr/lib/python3.6/site-packages/pulpcore/plugin/stages/api.py", line 225, in create_pipeline
          await asyncio.gather(*futures)
        File "/usr/lib/python3.6/site-packages/pulpcore/plugin/stages/api.py", line 43, in __call__
          await self.run()
        File "/usr/lib/python3.6/site-packages/pulpcore/plugin/stages/content_stages.py", line 105, in run
          d_content.content.q()
        File "/usr/lib/python3.6/site-packages/django/db/models/manager.py", line 82, in manager_method
          return getattr(self.get_queryset(), name)(*args, **kwargs)
        File "/usr/lib/python3.6/site-packages/django/db/models/query.py", line 408, in get
          self.model._meta.object_name
    description: Package matching query does not exist.
  worker: "/pulp/api/v3/workers/135dc424-94fb-4e18-9fc6-c6549530c8cd/"
  child_tasks: []
  progress_reports:
  - message: Parsed Packages
    code: parsing.packages
    state: completed
    total: 199
    done: 199
  - message: Downloading Metadata Files
    code: downloading.metadata
    state: completed
    done: 4
  - message: Downloading Artifacts
    code: downloading.artifacts
    state: completed
    done: 0
  - message: Associating Content
    code: associating.content
    state: canceled
    done: 0
  - message: Un-Associating Content
    code: unassociating.content
    state: canceled
    done: 0
  created_resources: []
  reserved_resources_record:
  - "/pulp/api/v3/repositories/rpm/rpm/15bb570c-705c-46e2-bae5-8e3b41cfb583/"
  - "/pulp/api/v3/remotes/rpm/rpm/6144e1fc-7b8e-489c-9517-46fd02472156/"
create_version: true
task_groups: []
poll_attempts:
  total: 6
  failed: 1

Related issues

Is duplicate of RPM Support - Issue #8052: Some repositories cannot be synchronized with error: Artifact() got an unexpected keyword argument 'sha'CLOSED - CURRENTRELEASE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#2 Updated by iballou 8 months ago

The workaround for the issue was to delete the related repositories and content views in Katello, run orphan cleanup, and then re-create and re-sync the repositories. This seems to be pointing to some sort of data corrupt from the migration.

#3 Updated by iballou 8 months ago

Updating Pulp versions to the following does not fix the issue:

pulp-2to3-migration (0.9.1)
pulp-certguard (1.0.3)
pulp-container (2.1.0)
pulp-deb (2.7.0)
pulp-file (1.3.0)
pulp-rpm (3.9.0)
pulpcore (3.7.3)

#4 Updated by ttereshc 8 months ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to ttereshc
  • Triaged changed from No to Yes
  • Sprint set to Sprint 93
  • Quarter set to Q1-2021

#5 Updated by ttereshc 8 months ago

This is fixed in pulp_rpm 3.10 as a part of this issue https://pulp.plan.io/issues/8052

#6 Updated by ttereshc 8 months ago

  • Status changed from ASSIGNED to CLOSED - DUPLICATE

#7 Updated by ttereshc 8 months ago

  • Is duplicate of Issue #8052: Some repositories cannot be synchronized with error: Artifact() got an unexpected keyword argument 'sha' added

Please register to edit this issue

Also available in: Atom PDF