Project

Profile

Help

Task #8388

Handle ALLOWED_CONTENT_CHECKSUMS setting

Added by quba42 7 months ago. Updated 6 months ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Urgent
Assignee:
-
Sprint/Milestone:
Start date:
Due date:
% Done:

100%

Estimated time:
Platform Release:
Target Release - Debian:
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

Right now the pulp_deb plugin is dependend on the following hashs being present on artifacts: md5, sha1, sha256, sha512.

Starting with pulpcore 3.11 will exclude md5 and sha1 from ALLOWED_CONTENT_CHECKSUMS by default.

Pulp deb will need to handle this gracefully. There is still some debate on whether pulp_deb makes sense without md5 feature wise. As a result, the solution may need to include demanding or encouraging a different configuration from pulp_deb users than the pulpcore default configuration.

See the following mailing list threads:

Associated revisions

Revision f29580ef View on GitHub
Added by quba42 6 months ago

Handle ALLOWED_CONTENT_CHECKSUMS parameter

fixes #8388 https://pulp.plan.io/issues/8388

History

#1 Updated by pulpbot 6 months ago

  • Status changed from NEW to POST

#2 Updated by quba42 6 months ago

  • Sprint/Milestone set to 2.10.0

#3 Updated by quba42 6 months ago

  • Status changed from POST to MODIFIED
  • % Done changed from 0 to 100

#4 Updated by pulpbot 6 months ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE

Please register to edit this issue

Also available in: Atom PDF