Project

Profile

Help

Issue #7829

Export fails if directory exists but is not owned by the worker

Added by daviddavis 5 months ago. Updated 4 months ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
Category:
-
Sprint/Milestone:
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Sprint 86
Quarter:

Description

Assume that you have a directory that exists and is writable but you don't own it. You should be able to export to it but it fails currently.

Steps to reproduce:

$ sudo mkdir /data
$ sudo chmod -r 777 /data
$ pulp file remote create --name test --url https://fixtures.pulpproject.org/file/PULP_MANIFEST 
$ pulp file repository create --name test --remote test
$ pulp exporter pulp create --name test --path /data --repository test file
$ pulp export pulp run --exporter test

Error:

File "/home/vagrant/devel/pulpcore/pulpcore/app/tasks/export.py", line 172, in pulp_export
    os.chmod(pulp_exporter.path, 0o775)  # let owner and group read and write the directory
PermissionError: [Errno 1] Operation not permitted: '/data'

Associated revisions

Revision 9b0c86eb View on GitHub
Added by daviddavis 5 months ago

Fixed exports to writable but not owned paths

fixes #7829

History

#1 Updated by pulpbot 5 months ago

  • Status changed from ASSIGNED to POST

#2 Updated by daviddavis 5 months ago

  • Description updated (diff)

#3 Updated by ggainey 5 months ago

  • Triaged changed from No to Yes
  • Sprint changed from Sprint 85 to Sprint 86

#4 Updated by daviddavis 5 months ago

  • Sprint/Milestone set to 3.9.0

Adding this to 3.9 since it's a small change and already in POST.

#5 Updated by daviddavis 5 months ago

  • Status changed from POST to MODIFIED

#6 Updated by pulpbot 4 months ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE

Please register to edit this issue

Also available in: Atom PDF