Project

Profile

Help

Issue #7734

closed

Validate the requirements.yml file

Added by daviddavis almost 2 years ago. Updated 11 months ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Sprint/Milestone:
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Platform Release:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

Ticket moved to GitHub: "pulp/pulp_ansible/714":https://github.com/pulp/pulp_ansible/issues/714


Validate the requirements.yml when a remote is saved.

Some examples:

  • Validate the presence of required keys (name, source) if the entry is a hash
  • Validate that type matches up with whatever types we support (ie only galaxy at this point)

Related issues

Related to Ansible Plugin - Issue #7686: requirements.yml is not compatible with ansible-galaxyCLOSED - CURRENTRELEASEdaviddavisActions
Actions #1

Updated by daviddavis almost 2 years ago

  • Related to Issue #7686: requirements.yml is not compatible with ansible-galaxy added
Actions #2

Updated by daviddavis almost 2 years ago

  • Description updated (diff)
Actions #4

Updated by fao89 over 1 year ago

  • Sprint/Milestone set to 1.0.0 - Candidates
Actions #5

Updated by fao89 over 1 year ago

  • Sprint/Milestone deleted (1.0.0 - Candidates)
Actions #6

Updated by fao89 about 1 year ago

  • Sprint/Milestone set to 1.0.0 - Candidates
Actions #7

Updated by pulpbot 11 months ago

  • Description updated (diff)
  • Status changed from NEW to CLOSED - DUPLICATE

Also available in: Atom PDF