Project

Profile

Help

Issue #7521

closed

Performing a filesystem export fails

Added by daviddavis about 2 years ago. Updated about 2 years ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
Category:
-
Sprint/Milestone:
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Sprint 81
Quarter:

Description

Steps to reproduce

Run this script: https://github.com/pulp/pulp_file/blob/master/docs/_scripts/export.sh

Result

This failure:

rq[9925]: Traceback (most recent call last):
rq[9925]:   File "/usr/local/lib/pulp/lib64/python3.7/site-packages/rq/worker.py", line 886, in perform_job
rq[9925]:     rv = job.perform()
rq[9925]:   File "/usr/local/lib/pulp/lib64/python3.7/site-packages/rq/job.py", line 664, in perform
rq[9925]:     self._result = self._execute()
rq[9925]:   File "/usr/local/lib/pulp/lib64/python3.7/site-packages/rq/job.py", line 670, in _execute
rq[9925]:     return self.func(*self.args, **self.kwargs)
rq[9925]:   File "/home/vagrant/devel/pulpcore/pulpcore/app/tasks/export.py", line 49, in fs_publication_export
rq[9925]: exporter.export_publication(publication)
rq[9925]:   File "/home/vagrant/devel/pulpcore/pulpcore/app/models/exporter.py", line 130, in export_publication
rq[9925]: self._export_to_file_system(content_artifacts)
rq[9925]:   File "/home/vagrant/devel/pulpcore/pulpcore/app/models/exporter.py", line 89, in _export_to_file_system
rq[9925]: ExportSerializer.validate_path(self.path)
rq[9925]: AttributeError: type object 'ExportSerializer' has no attribute 'validate_path'
Actions #1

Updated by daviddavis about 2 years ago

  • Description updated (diff)
Actions #2

Updated by bmbouter about 2 years ago

  • Triaged changed from No to Yes
  • Sprint set to Sprint 81
Actions #3

Updated by daviddavis about 2 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to daviddavis
Actions #4

Updated by pulpbot about 2 years ago

  • Status changed from ASSIGNED to POST

Added by daviddavis about 2 years ago

Revision 6343df7a

Fixed failing filesystem export due to undefined validate_path method

Just removing the call since we're already validating the path in the serializer. Also, adding some tests so we don't break this functionality again later.

Required PR: https://github.com/pulp/pulp_file/pull/429

fixes #7521

Actions #5

Updated by daviddavis about 2 years ago

  • Status changed from POST to MODIFIED
Actions #6

Updated by bmbouter about 2 years ago

  • Sprint/Milestone set to 3.7.0
Actions #7

Updated by pulpbot about 2 years ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE

Also available in: Atom PDF