Project

Profile

Help

Task #7421

Story #7416: [Epic] As a plugin user, I can use the next verison of pulpcore without upgrading my plugin

Add deprecation support to the plugin template

Added by daviddavis 10 months ago. Updated 9 months ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
Category:
-
Sprint/Milestone:
Start date:
Due date:
% Done:

100%

Estimated time:
Platform Release:
Groomed:
No
Sprint Candidate:
No
Tags:
Plugin Template
Sprint:
Quarter:

Description

Two things to do:

  1. Update the commit validation to recognize 'deprecation' as a possible changelog type
  2. Add the deprecation type to towncrier's configuration

Associated revisions

Revision bd7115f1 View on GitHub
Added by daviddavis 10 months ago

Added support for deprecation type to towncrier

fixes #7421

History

#1 Updated by daviddavis 10 months ago

  • Parent task set to #7416

#2 Updated by pulpbot 10 months ago

  • Status changed from NEW to POST

#3 Updated by daviddavis 10 months ago

  • Tracker changed from Issue to Task
  • Assignee set to daviddavis
  • % Done set to 0
  • Severity deleted (2. Medium)
  • Triaged deleted (No)

#4 Updated by daviddavis 10 months ago

  • Tags Plugin Template added

#5 Updated by daviddavis 10 months ago

  • Status changed from POST to MODIFIED
  • % Done changed from 0 to 100

#6 Updated by bmbouter 9 months ago

  • Sprint/Milestone set to 3.7.0

#7 Updated by bmbouter 9 months ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE

Please register to edit this issue

Also available in: Atom PDF