Project

Profile

Help

Issue #7295

closed

Structured publish for synced repos with components with extra path prefixes duplicates the path prefix for indices

Added by quba42 over 2 years ago. Updated over 1 year ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
High
Assignee:
-
Sprint/Milestone:
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version - Debian:
Platform Release:
Target Release - Debian:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

See here: https://wiki.debian.org/DebianRepository/Format#Components

"(Components) May also be prefixed by parts of the path following the directory beneath dists, if the Release file is not in a directory directly beneath dists/."

The structured publisher builds the following path for package indices:

REPO_ROOT + "dists/" + DISTRIBUTION + COMPONENT + "/binary-" + ARCHITECTURE + "/" + FILENAME

The problem is that DISTRIBUTION already includes the extra path prefixes that may also be included in COMPONENT, causing them to be duplicated in the path.

The solution is to strip any prefixes from the COMPONENT as extracted from the Release files when building paths.


Related issues

Related to Debian Support - Test #6051: Add tests for known cases where the distribution is not the codename or suiteCLOSED - COMPLETEquba42Actions
Actions #1

Updated by quba42 over 2 years ago

  • Related to Test #6051: Add tests for known cases where the distribution is not the codename or suite added

Added by quba42 over 2 years ago

Revision bb93c33d

Add the plain_component property

fixes #7295 https://pulp.plan.io/issues/7295

Most of the changes refactor existing names and calls for readability. The only exception is that replacing self.name with self.plain_component (rather than self.component) in publishing.py actually fixes the bug from the associated ticket.

https://pulp.plan.io/issues/6051 Has added test coverage for this issue.

Actions #2

Updated by quba42 over 2 years ago

  • Status changed from NEW to MODIFIED
Actions #3

Updated by quba42 over 2 years ago

  • Sprint/Milestone changed from Katello to 2.6.0b1
Actions #4

Updated by quba42 over 1 year ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE

Also available in: Atom PDF