Project

Profile

Help

Issue #7220

When a task crashes, the incomplete repo version is not cleaned up and leads to duplicate key error when creating new repo versions

Added by OnceUponALoop 4 months ago. Updated 2 months ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Category:
Operator
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Master
Platform Release:
OS:
CentOS 7
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

Pulp v3 - rpm plugin

Set up a pulp server on a CentOS 7 host with 4GB of RAM and 4GB of swap.

Configured server to synchronize three RHEL repos (rhel-7-server-rpms,rhel-7-server-optional-rpms, rhel-7-server-extras-rpms).

Synchronization successful for extras and optional - fails when synchronizing the main repo.

The fact that a few of the repos succeeded indicated that the configuration was correct (proper client_ca, client_key, and ca_cert).

Subsequent runs after the failure resulted in the error observed in the attached "duplicate-key-error.json"

I debugged this further and found the failure was most likely caused by running out of memory and swap. Once I increased the available swap (using a local /swapfile) I was able to successfully synchronize.

repo-configuration.json (647 Bytes) repo-configuration.json OnceUponALoop, 07/27/2020 08:38 PM
duplicate-key-error.json (3.92 KB) duplicate-key-error.json OnceUponALoop, 07/27/2020 08:38 PM
remote-configuration.json (1.02 KB) remote-configuration.json OnceUponALoop, 07/27/2020 08:38 PM
sync-result.json (2.96 KB) sync-result.json OnceUponALoop, 07/27/2020 08:38 PM
pulp-status.json (1.98 KB) pulp-status.json OnceUponALoop, 07/27/2020 08:38 PM

Related issues

Is duplicate of Pulp - Issue #6463: pulp 3.2.1 duplicate key error when syncCLOSED - CURRENTRELEASE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by OnceUponALoop 4 months ago

Once the swap was increased the issue was not resolved, the duplication error in "duplicate-key-error.json" was still being output anytime a re-synchronization as attempted.

It wasn't until both the repository and the remote were deleted and recreated that I was able to successfully synchronize again.

#2 Updated by dkliban@redhat.com 4 months ago

When a repository version is not complete and the task associated with that repository version is in a final state, we should be cleaning up the incomplete repository version.

#3 Updated by fao89 4 months ago

  • Triaged changed from No to Yes

#4 Updated by daviddavis 3 months ago

  • Subject changed from Synchronization Failure due to RAM/Swap exhaustion to When a task crashes, the incomplete repo version is not cleaned up and leads to duplicate key error when creating new repo versions

#5 Updated by dalley 2 months ago

  • Status changed from NEW to CLOSED - DUPLICATE

Thank you! This should be fixed soon.

#6 Updated by dalley 2 months ago

  • Is duplicate of Issue #6463: pulp 3.2.1 duplicate key error when sync added

Please register to edit this issue

Also available in: Atom PDF