Project

Profile

Help

Issue #7047

closed

Checksum type "sha256" is not available for all units in the repository. Make sure those units have been downloaded

Added by hyu almost 2 years ago. Updated almost 2 years ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
3. High
Version:
2.21.1
Platform Release:
2.21.3
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Cloned from: https://bugzilla.redhat.com/show_bug.cgi?id=1850914

Description of problem: Below is the steps that how the error will happen:

  1. There is a sha1 srpm in downstream Pulp repo 'A' which was previously synced.
  2. Upstream repo 'A' deleted the srpm and switched to sha256 metadata
  3. Downstream pulp (still in sha1) sync with upstream pulp and fail with:

Checksum type "sha256" is not available for all units in the repository. Make sure those units have been downloaded

It is because there is a bug in Pulp that never delete the srpm. The srpm already deleted in the upstream pulp so downstream pulp is not able to determine the sha256 of the srpm which causes the error.

Steps to Reproduce:

  1. Create a "sha1" local repository with 1 rpm and 1 srpm in /var/www/html/pub/my_local_repo

createrepo -s sha1 /var/www/html/pub/my_local_repo

  1. Create a repo from the satellite web UI to sync the local repo.
  2. Sync the repo and wait until it is succeeded.
  3. Remove the the "repodata" and the srpm in /var/www/html/pub/my_local_repo
  4. Recreate a sha256 repo

createrepo /var/www/html/pub/my_local_repo

  1. Sync the repo again and get the following error.

Actual results: Checksum type "sha256" is not available for all units in the repository. Make sure those units have been downloaded

Expected results: Remove missing should remove srpm too.

Actions #2

Updated by daviddavis almost 2 years ago

  • Project changed from Pulp to RPM Support
Actions #3

Updated by pulpbot almost 2 years ago

  • Status changed from NEW to POST
Actions #4

Updated by ttereshc almost 2 years ago

  • Triaged changed from No to Yes

Added by hyu almost 2 years ago

Revision 504e2b66

Remove missing should also remove missing srpms

closes #7047 https://pulp.plan.io/issues/7047

Actions #5

Updated by hyu almost 2 years ago

  • Status changed from POST to MODIFIED

Added by hyu almost 2 years ago

Revision 3cb31205

Remove missing should also remove missing srpms

closes #7047 https://pulp.plan.io/issues/7047

Actions #7

Updated by hyu almost 2 years ago

Actions #8

Updated by ttereshc almost 2 years ago

  • Platform Release set to 2.21.3
  • Tags Pulp 2 added
Actions #9

Updated by ttereshc almost 2 years ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE

Also available in: Atom PDF