Project

Profile

Help

Issue #6982

closed

Pulp 3 - pulp-deb : APT client installing same patches again and again

Added by swisscom about 2 years ago. Updated over 1 year ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
4. Urgent
Version - Debian:
master
Platform Release:
Target Release - Debian:
OS:
CentOS 7
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

Dear support team, When setting up APT client to connect to Pulp to get it's content, I discovered that it installs the same patches again and again. Like if I run twice "apt-get upgrade -y", it will install 339 packages the two times.

The issue is due to the fact the "Installed-Size" field is missing in the Packages file produced by Pulp. "Installed-Size" is one of the mandatory fields, that is used by APT client to check if the patch is already installed or not.

Mpore information here : https://github.com/Debian/apt/issues/23 The following fields must be the same in the Packages file and /var/lib/dpkg status: "Installed-Size", "Depends", "Pre-Depends", "Conflicts", "Breaks", "Replaces". All spaces are ignored, all values are transformed to lowercase, and <= and >= are normalized into < and >.

Would it be possible to fix this issue ?

Thanks a lot

Also available in: Atom PDF