Project

Profile

Help

Issue #678

closed

Our Celery packages depend on the existence of the apache user

Added by rbarlow over 7 years ago. Updated about 3 years ago.

Status:
CLOSED - WONTFIX
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
1. Low
Version:
2.4.3
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Description of problem:
If users wish to install our Celery packages on a system that does not have httpd installed, the apache user will not exist. However, the Celery packages all assume that the apache user does exist. There is a reasonable workaround[0], but we could also take steps to fix this such as creating a "pulp" user and running all processes as it. We could also attempt to create the apache user ourselves, though I believe the pulp user may be more appropriate. In any case, it will be important for us to ensure that the user always has the same UID/GID. Using the existing "apache" user might help with this, as it seems to always have UID:GID of 48:48 for Red Hat based systems (I checked F20 and RHEL 7.)

Version-Release number of selected component (if applicable):
2.4.3-1

How reproducible:
Every time.

Steps to Reproduce:
1. Configure a Pulp worker box that does not have httpd installed on it.
2. Attempt to start the workers.

Actual results:
The workers will fail to start, because the system will attempt to run them as the apache user, which does not exist.

Expected results:
The workers should start out of the box.

Additional info:
[0] A workaround is to manually create the apache user, using the same UID/GID as it has on the other systems that are sharing the filesystem.

+ This bug was cloned from Bugzilla Bug #1186414 +

Actions #1

Updated by bmbouter over 7 years ago

  • Severity changed from Low to 1. Low
Actions #2

Updated by bmbouter about 3 years ago

  • Status changed from NEW to CLOSED - WONTFIX
Actions #3

Updated by bmbouter about 3 years ago

Pulp 2 is approaching maintenance mode, and this Pulp 2 ticket is not being actively worked on. As such, it is being closed as WONTFIX. Pulp 2 is still accepting contributions though, so if you want to contribute a fix for this ticket, please reopen or comment on it. If you don't have permissions to reopen this ticket, or you want to discuss an issue, please reach out via the developer mailing list.

Actions #4

Updated by bmbouter about 3 years ago

  • Tags Pulp 2 added

Also available in: Atom PDF