Project

Profile

Help

Task #6708

Pulp - Task #6707: [Epic] Move requirements out of setup.py

Move requirements out of setup.py

Added by fao89 over 1 year ago. Updated over 1 year ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
-
Sprint/Milestone:
Start date:
Due date:
% Done:

100%

Estimated time:
Platform Release:
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

While working on #6600 I realized using bump2version on a setup.py file could cause a change in requirements: https://github.com/pulp/pulp_file/pull/390#discussion_r423272806

Another benefit from moving it out, we can provide requirements with hashes: https://github.com/flask-extensions/Flask-GoogleMaps/blob/master/requirements.txt

Associated revisions

Revision b83e5c91 View on GitHub
Added by Fabricio Aguiar over 1 year ago

Move requirements out of setup.py

https://pulp.plan.io/issues/6708 closes #6708

History

#1 Updated by fao89 over 1 year ago

  • Project changed from Pulp to File Support

#2 Updated by pulpbot over 1 year ago

  • Status changed from NEW to POST

#3 Updated by fao89 over 1 year ago

  • Description updated (diff)

#4 Updated by Anonymous over 1 year ago

  • Status changed from POST to MODIFIED
  • % Done changed from 0 to 100

#5 Updated by dkliban@redhat.com over 1 year ago

  • Sprint/Milestone set to 1.0.0

#6 Updated by dkliban@redhat.com over 1 year ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE

Please register to edit this issue

Also available in: Atom PDF