Project

Profile

Help

Task #6557

closed

Story #5890: [Epic] The ansible-pulp installer needs to handle multiple versions of Pulp

Story #5618: As a user, I can download & run a version of the ansible installer that a specific version of Pulp 3

Task #6073: Adapt pulp_installer CI for pulp_installer branches

Add "Required PR" support for pulpcore & plugins to pulp_installer

Added by mdepaulo@redhat.com about 2 years ago. Updated over 1 year ago.

Status:
CLOSED - WONTFIX
Priority:
Normal
Assignee:
-
Category:
Installer - Moved to GitHub issues
Sprint/Milestone:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
Groomed:
No
Sprint Candidate:
No
Tags:
CI/CD
Sprint:
Quarter:

Description

It should be added to pulp_installer.git/molecule/prepare.yml , which git clones the repos withhin the molecule VM-like container.

This was not part of the original scope of the parent task, but it will be necessary at some point.

Actions #1

Updated by mdepaulo@redhat.com about 2 years ago

Example:

---
- hosts: all
  tasks:
  # Does not support being re-run, with or without updates=yes
  - git:
      repo: "https://github.com/pulp/pulpcore/"
      dest: /tmp/pulpcore
      version: '630'
      refspec: 'pull/630/head:630'
Actions #2

Updated by bmbouter about 2 years ago

  • Category set to Installer - Moved to GitHub issues
  • Tags deleted (Pulp 3 installer)
Actions #3

Updated by mdepaulo@redhat.com over 1 year ago

  • Status changed from ASSIGNED to CLOSED - WONTFIX
  • Assignee deleted (mdepaulo@redhat.com)

OBE - we haven't had a need for this yet due to reduced branching in pulp_installer and pulp_rpm_prerequisites being merged into pulp_installer. So let's remove it from our backlog.

Also available in: Atom PDF