Project

Profile

Help

Task #6073

Story #5890: [Epic] The ansible-pulp installer needs to handle multiple versions of Pulp

Story #5618: As a user, I can download & run a version of the ansible installer that a specific version of Pulp 3

Adapt pulp_installer CI for pulp_installer branches

Added by mdepaulo@redhat.com over 1 year ago. Updated 3 months ago.

Status:
CLOSED - COMPLETE
Priority:
Normal
Category:
Installer
Sprint/Milestone:
-
Start date:
Due date:
% Done:

100%

Estimated time:
(Total: 0:00 h)
Platform Release:
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

like 3.0 vs 3.1 vs master

Currently, there is no different logic (for system config, packages installed, etc) needed by the master branch (soon 3.1.0) vs what's needed by 3.0.1. The installer can install both versions of pulpcore depending on variables.

But this task will be needed as soon as the logic differs.


Subtasks

Task #6535: Separate the pulp_installer CI jobs: release vs sourceCLOSED - CURRENTRELEASEmdepaulo@redhat.com

Actions
Task #6547: pulp_installer: Add variables for molecule prepare.yml to clone the branchesCLOSED - CURRENTRELEASErochacbruno

Actions
Task #6548: pulp_installer CI: prereq roles to use variables for what branches they test againstCLOSED - WONTFIXmdepaulo@redhat.com

Actions
Task #6549: pulp_installer CI: prereq roles to clone the desired branch / release of pulp_installerCLOSED - WONTFIX

Actions
Task #6550: pulp_installer CI: Modify tag jobs to only run release testsCLOSED - CURRENTRELEASE

Actions
Task #6551: pulp_installer: Implement support for PyPI pre-releasesCLOSED - WONTFIX

Actions
Task #6552: pulp_installer CI: Create docs or scripts to help maintain which branches & tests get usedCLOSED - WONTFIX

Actions
Task #6553: Add "Required PR" support for pulp_installer to prereq rolesCLOSED - CURRENTRELEASE

Actions
Task #6557: Add "Required PR" support for pulpcore & plugins to pulp_installerCLOSED - WONTFIX

Actions

Related issues

Related to Pulp - Story #5762: [Epic] CI ImprovementsASSIGNED

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>
Related to Pulp - Story #8846: As a pulp_installer user, I do not need to use the latest micro release to install the latest micro release of pulpcoreNEW

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

Associated revisions

Revision 39da0121 View on GitHub
Added by Mike DePaulo over 1 year ago

Temporarily force release CI tests to use pulpcore 3.2.1

Revert for pulp_rpm 3.3.0 release.

[noissue]

re: #6073 6073: Adapt ansible-pulp CI for ansible-pulp branches

History

#1 Updated by mdepaulo@redhat.com over 1 year ago

#2 Updated by mdepaulo@redhat.com over 1 year ago

  • Subject changed from Adapt ansible-pulp CI for ansible-pulp branches to Adapt pulp_installer CI for ansible-pulp branches
  • Assignee set to mdepaulo@redhat.com

#3 Updated by mdepaulo@redhat.com over 1 year ago

The test matrix, and other details, discussed in the CI team meeting: https://docs.google.com/spreadsheets/d/1OYrazt7oClSovsgaXuO_S4c8_1PRebdUuvcUo7UvgvE/edit#gid=0

#4 Updated by mdepaulo@redhat.com over 1 year ago

  • Status changed from NEW to ASSIGNED

#5 Updated by bmbouter 12 months ago

  • Category set to Installer

#6 Updated by mdepaulo@redhat.com 11 months ago

  • Subject changed from Adapt pulp_installer CI for ansible-pulp branches to Adapt pulp_installer CI for pulp_installer branches

#7 Updated by mdepaulo@redhat.com 3 months ago

  • Related to Story #8846: As a pulp_installer user, I do not need to use the latest micro release to install the latest micro release of pulpcore added

#8 Updated by mdepaulo@redhat.com 3 months ago

  • Status changed from ASSIGNED to CLOSED - COMPLETE

All subtasks completed.

Please register to edit this issue

Also available in: Atom PDF