Project

Profile

Help

Issue #649

closed

https://repos.fedorapeople.org/repos/pulp/pulp/rhel-pulp.repo does not work on Centos7

Added by jon@soh.re almost 8 years ago. Updated almost 4 years ago.

Status:
CLOSED - WORKSFORME
Priority:
High
Assignee:
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
1. Low
Version:
2.5
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Documentation, Easy Fix, Pulp 2
Sprint:
Quarter:

Description

Description of problem:
The .repo file does not work with a fresh Centos 7 box. Specifically $releasever on Centos7 resolves as "7" where as the pulp repo is expecting it to resolve to "7Server", because of this, people are unable to follow the getting started guide on https://pulp-user-guide.readthedocs.org/en/2.5-release/installation.html.

The fix is, to edit the .repo file from $releasever to "$releasever"Server

Version-Release number of selected component (if applicable):

How reproducible:
100%

Steps to Reproduce:
1. Build a new Centos7 Box
2. Wget the repo
3. Yum update and watch the url fail

Actual results:
https://repos.fedorapeople.org/repos/pulp/pulp/stable/2/7/x86_64/repodata/repomd.xml: [Errno 14] HTTPS Error 404 - Not Found

Expected results:
pulp-2-stable | 3.6 kB 00:00:00
(1/2): pulp-2-stable/7/x86_64/group_gz | 521 B 00:00:00
(2/2): pulp-2-stable/7/x86_64/primary_db | 22 kB 00:00:00

Additional info:

Document URL:

Section Number and Name:

Describe the issue:

Suggestions for improvement:

Additional information:

Description of problem:

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:

Expected results:

Additional info:

Document URL:

Section Number and Name:

Describe the issue:

Suggestions for improvement:

Additional information:

+ This bug was cloned from Bugzilla Bug #1178241 +

Also available in: Atom PDF