Project

Profile

Help

Issue #627

--checksum-type does not affect the checksum used in primary.xml

Added by rbarlow over 5 years ago. Updated over 1 year ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
2.4.0
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Description of problem:
Setting the --checksum-type on a repo does not seem to have an effect.

Version-Release number of selected component (if applicable):
2.4.3-1

How reproducible:
Every time

Steps to Reproduce:
1. Create a repo, perhaps the zoo repo, setting --checksum-type sha1
2. Sync & Publish

Actual results:
Open the primary.xml.gz file in the published repodata folder. Observe that sha256 was used. For example, I see this tag in the bear package:

<checksum pkgid="YES" type="sha256">7a831f9f90bf4d21027572cb503d20b702de8e8785b02c0397445c2e481d81b3</checksum>

Expected results:
I expected sha1 to have been used, since I explicitly chose sha1.

Additional info:
I wonder if this is because I sync'd the repo, and perhaps the upstream zoo repo used sha256 and that overrides the --checksum-type flag? I think it's a bug either way, since the --checksum-type flag helptext doesn't list any conditions on whether it gets used.

+ This bug was cloned from Bugzilla Bug #1167456 +


Related issues

Is duplicate of RPM Support - Issue #1618: --checksum-type is brokenCLOSED - CURRENTRELEASE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by rbarlow over 5 years ago

I tried creating repos without feeds and uploading packages to them with the --checksum-type set to "sha", but the primary.xml still shows sha256 as the checksum type used.

+ This comment was cloned from Bugzilla #1167456 comment 1 +

#2 Updated by bmbouter over 5 years ago

This behavior should be documented in the help-text and docs. It should note that checksum types can be set in multiple places. ie: upload, repo create, etc.

+ This comment was cloned from Bugzilla #1167456 comment 2 +

#3 Updated by bcourt over 5 years ago

This behavior is by design. A documentation update would probably be good however the current user guide doesn't elaborate on the --checksum-type option much at all. We do not currently recalculate the checksums for individual content units. the --checksum-type parameter is only for the metadata files that are generated as part of the repo publish.

#4 Updated by bmbouter over 5 years ago

  • Severity changed from Medium to 2. Medium

#5 Updated by jcline@redhat.com over 4 years ago

  • Status changed from NEW to CLOSED - DUPLICATE

Even though this is much older, https://pulp.plan.io/issues/1618 has far more activity so I'm closing this as a duplicate of that.

#6 Updated by bmbouter over 4 years ago

  • Is duplicate of Issue #1618: --checksum-type is broken added

#7 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF