Project

Profile

Help

Issue #573

nodes.conf is blank by default, but the config loader does not have defaults for at least one setting

Added by rbarlow about 6 years ago. Updated almost 2 years ago.

Status:
CLOSED - WORKSFORME
Priority:
High
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Master
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Description of problem:
I noticed today that I could not run pulp-dev.py -I because my nodes.conf has the ca_path setting commented out.

Version-Release number of selected component (if applicable):
master

How reproducible:
Every time.

Steps to Reproduce:
1. Comment out all of nodes.conf.
2. Run sudo ./pulp-dev -I

Actual results:
<snip>
Traceback (most recent call last):
File "<string>", line 2, in <module>
File "/home/rbarlow/devel/pulp/nodes/common/pulp_node/resources.py", line 43, in node_configuration
cfg.validate(NODE_SCHEMA)
File "/home/rbarlow/devel/pulp/common/pulp/common/config.py", line 296, in validate
return v.validate(self)
File "/home/rbarlow/devel/pulp/common/pulp/common/config.py", line 360, in validate
s.validate(section)
File "/home/rbarlow/devel/pulp/common/pulp/common/config.py", line 476, in validate
self.validproperty(section, property)
File "/home/rbarlow/devel/pulp/common/pulp/common/config.py", line 494, in validproperty
raise pe
pulp.common.config.PropertyNotFound: Required property "main.ca_path", not found

Expected results:
The ca_path should be allowed to be undefined in nodes.conf.

+ This bug was cloned from Bugzilla Bug #1150754 +

History

#1 Updated by jortel@redhat.com about 6 years ago

So far, I cannot reproduce on master or 2.5-dev. Randy, can you attach your nodes.conf?

+ This comment was cloned from Bugzilla #1150754 comment 1 +

#2 Updated by bmbouter almost 6 years ago

  • Severity changed from Medium to 2. Medium

#3 Updated by jortel@redhat.com almost 6 years ago

  • Status changed from ASSIGNED to CLOSED - WORKSFORME

Randy, please re-open if you can reproduce.

#4 Updated by bmbouter almost 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF