Project

Profile

Help

Issue #5636

Dependency version conflicts between pulp plugins and pulp installation with ansible-pulp

Added by Anonymous 12 months ago. Updated 6 months ago.

Status:
CLOSED - WONTFIX
Priority:
Normal
Assignee:
-
Category:
Installer
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
CentOS 7
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

Install Pulp with ansible-pulp allows specifying which plugins to install with the `pulp_install_plugins` variable, e.g.:

pulp_install_plugins:
  pulp-file: {}
  pulp-docker: {}

Unfortunately, this leads to the following error:

RUNNING HANDLER [pulp : Collect static content] ********************************
task path: /home/funke_t1/code/ansible/hss/plays/pulp/pulp/roles/pulp/handlers/main.yml:10
fatal: [pulp-dev-1.mgmt.hss.int]: FAILED! => {"changed": true, "cmd": ["/usr/local/lib/pulp/bin/django-admin", "collectstatic", "--noinput", "--link"], "delta": "0:00:00.683171", "end": "2019-10-29 16:44:47.097737", "msg": "non-zero return code", "rc": 1, "start": "2019-10-29 16:44:46.414566", "stderr": "Traceback (most recent call last):\n  File \"/usr/local/lib/pulp/bin/django-admin\", line 11, in <module>\n    sys.exit(execute_from_command_line())\n  File \"/usr/local/lib/pulp/lib64/python3.6/site-packages/django/core/management/__init__.py\", line 381, in execute_from_command_line\n    utility.execute()\n  File \"/usr/local/lib/pulp/lib64/python3.6/site-packages/django/core/management/__init__.py\", line 325, in execute\n    settings.INSTALLED_APPS\n  File \"/usr/local/lib/pulp/lib64/python3.6/site-packages/django/conf/__init__.py\", line 79, in __getattr__\n    self._setup(name)\n  File \"/usr/local/lib/pulp/lib64/python3.6/site-packages/django/conf/__init__.py\", line 66, in _setup\n    self._wrapped = Settings(settings_module)\n  File \"/usr/local/lib/pulp/lib64/python3.6/site-packages/django/conf/__init__.py\", line 157, in __init__\n    mod = importlib.import_module(self.SETTINGS_MODULE)\n  File \"/usr/lib64/python3.6/importlib/__init__.py\", line 126, in import_module\n    return _bootstrap._gcd_import(name[level:], package, level)\n  File \"<frozen importlib._bootstrap>\", line 994, in _gcd_import\n  File \"<frozen importlib._bootstrap>\", line 971, in _find_and_load\n  File \"<frozen importlib._bootstrap>\", line 955, in _find_and_load_unlocked\n  File \"<frozen importlib._bootstrap>\", line 665, in _load_unlocked\n  File \"<frozen importlib._bootstrap_external>\", line 678, in exec_module\n  File \"<frozen importlib._bootstrap>\", line 219, in _call_with_frames_removed\n  File \"/usr/local/lib/pulp/lib64/python3.6/site-packages/pulpcore/app/settings.py\", line 62, in <module>\n    plugin_app_config = entry_point.load()\n  File \"/usr/local/lib/pulp/lib64/python3.6/site-packages/pkg_resources/__init__.py\", line 2442, in load\n    self.require(*args, **kwargs)\n  File \"/usr/local/lib/pulp/lib64/python3.6/site-packages/pkg_resources/__init__.py\", line 2465, in require\n    items = working_set.resolve(reqs, env, installer, extras=self.extras)\n  File \"/usr/local/lib/pulp/lib64/python3.6/site-packages/pkg_resources/__init__.py\", line 791, in resolve\n    raise VersionConflict(dist, req).with_context(dependent_req)\npkg_resources.VersionConflict: (pulpcore-plugin 0.1.0rc7 (/usr/local/lib/pulp/lib/python3.6/site-packages), Requirement.parse('pulpcore-plugin==0.1.0rc6'))", "stderr_lines": ["Traceback (most recent call last):", "  File \"/usr/local/lib/pulp/bin/django-admin\", line 11, in <module>", "    sys.exit(execute_from_command_line())", "  File \"/usr/local/lib/pulp/lib64/python3.6/site-packages/django/core/management/__init__.py\", line 381, in execute_from_command_line", "    utility.execute()", "  File \"/usr/local/lib/pulp/lib64/python3.6/site-packages/django/core/management/__init__.py\", line 325, in execute", "    settings.INSTALLED_APPS", "  File \"/usr/local/lib/pulp/lib64/python3.6/site-packages/django/conf/__init__.py\", line 79, in __getattr__", "    self._setup(name)", "  File \"/usr/local/lib/pulp/lib64/python3.6/site-packages/django/conf/__init__.py\", line 66, in _setup", "    self._wrapped = Settings(settings_module)", "  File \"/usr/local/lib/pulp/lib64/python3.6/site-packages/django/conf/__init__.py\", line 157, in __init__", "    mod = importlib.import_module(self.SETTINGS_MODULE)", "  File \"/usr/lib64/python3.6/importlib/__init__.py\", line 126, in import_module", "    return _bootstrap._gcd_import(name[level:], package, level)", "  File \"<frozen importlib._bootstrap>\", line 994, in _gcd_import", "  File \"<frozen importlib._bootstrap>\", line 971, in _find_and_load", "  File \"<frozen importlib._bootstrap>\", line 955, in _find_and_load_unlocked", "  File \"<frozen importlib._bootstrap>\", line 665, in _load_unlocked", "  File \"<frozen importlib._bootstrap_external>\", line 678, in exec_module", "  File \"<frozen importlib._bootstrap>\", line 219, in _call_with_frames_removed", "  File \"/usr/local/lib/pulp/lib64/python3.6/site-packages/pulpcore/app/settings.py\", line 62, in <module>", "    plugin_app_config = entry_point.load()", "  File \"/usr/local/lib/pulp/lib64/python3.6/site-packages/pkg_resources/__init__.py\", line 2442, in load", "    self.require(*args, **kwargs)", "  File \"/usr/local/lib/pulp/lib64/python3.6/site-packages/pkg_resources/__init__.py\", line 2465, in require", "    items = working_set.resolve(reqs, env, installer, extras=self.extras)", "  File \"/usr/local/lib/pulp/lib64/python3.6/site-packages/pkg_resources/__init__.py\", line 791, in resolve", "    raise VersionConflict(dist, req).with_context(dependent_req)", "pkg_resources.VersionConflict: (pulpcore-plugin 0.1.0rc7 (/usr/local/lib/pulp/lib/python3.6/site-packages), Requirement.parse('pulpcore-plugin==0.1.0rc6'))"], "stdout": "", "stdout_lines": []}

It appears that pulp-docker tries to install rc6 version.

Further, this means that errors such as in the following issues can occur:
https://pulp.plan.io/issues/5626
https://pulp.plan.io/issues/5624

Consistent dependencies should be available when installing via anisble-pulp.

History

#1 Updated by ipanova@redhat.com 12 months ago

  • Status changed from NEW to CLOSED - WONTFIX

Hi, we do not have released docker plugin compatible with rc7.
At this point i suggest you to install all the plugins that are compatible with rc6 or soon we are going to release another core rc ( next week) and new docker release compatible with it.

#2 Updated by bmbouter 6 months ago

  • Category set to Installer
  • Tags deleted (Pulp 3 installer)

Please register to edit this issue

Also available in: Atom PDF