Project

Profile

Help

Issue #5426

orphan cleanup does not properly find orphaned content

Added by dkliban@redhat.com about 1 month ago. Updated about 1 month ago.

Status:
CLOSED - WONTFIX
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
Start date:
Due date:
Severity:
2. Medium
Version:
Platform Release:
Blocks Release:
OS:
Backwards Incompatible:
No
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
QA Contact:
Complexity:
Smash Test:
Verified:
No
Verification Required:
No
Sprint:

Description

Orphan clean up needs to find all content that is not in any repository version. The current query0 considers content NOT orphaned if it has ever been in any repository version. The query needs to take into consideration the 'version_added' and 'version_removed' fields1.

[0] https://github.com/pulp/pulpcore/blob/master/pulpcore/app/tasks/orphan.py#L10-L11
[1] https://github.com/pulp/pulpcore/blob/master/pulpcore/app/models/repository.py#L175-L179

History

#1 Updated by daviddavis about 1 month ago

  • Sprint/Milestone changed from 3.0 to 71

#2 Updated by amacdona@redhat.com about 1 month ago

  • Status changed from NEW to CLOSED - WONTFIX

This is a feature, not a bug.

If content belongs to any repository version, it should not be considered an orphan because users should be able to roll back to all previous repository versions, which is only possible if that content isn't deleted.

#3 Updated by bmbouter about 1 month ago

  • Sprint/Milestone changed from 71 to 3.0

Please register to edit this issue

Also available in: Atom PDF