Project

Profile

Help

Issue #5382

Fails to sync an artifactory apt repo

Added by jaymzh about 1 year ago. Updated about 2 months ago.

Status:
CLOSED - NOTABUG
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version - Debian:
Platform Release:
Target Release - Debian:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

The failure is:

$ http GET $pulp/pulp/api/v3/tasks/844f8e63-159f-4ef0-973e-ff008360a397/
HTTP/1.1 200 OK
Allow: GET, PATCH, DELETE, HEAD, OPTIONS
Connection: close
Content-Length: 2880
Content-Type: application/json
Date: Fri, 30 Aug 2019 20:33:00 GMT
Server: gunicorn/19.9.0
Vary: Accept, Cookie
X-Frame-Options: SAMEORIGIN

{
    "_created": "2019-08-30T20:32:54.029031Z",
    "_href": "/pulp/api/v3/tasks/844f8e63-159f-4ef0-973e-ff008360a397/",
    "created_resources": [],
    "error": {
        "code": null,
        "description": "No declared artifact with relative path \"chef-workstation_0.7.4-1_amd64.deb\" for content \"<Package: chef-workstation_0.7.4-1_amd64>\"",
        "traceback": "  File \"/var/pulp/pulpvenv/lib/python3.6/site-packages/rq/worker.py\", line 822, in perform_job\n    rv = job.perform()\n  File \"/var/pulp/pulpvenv/lib/python3.6/site-packages/rq/job.py\", line 605, in perform\n    self._result = self._execute()\n  File \"/var/pulp/pulpvenv/lib/python3.6/site-packages/rq/job.py\", line 611, in _execute\n    return self.func(*self.args, **self.kwargs)\n  File \"/var/pulp/pulp_deb/pulp_deb/app/tasks/synchronizing.py\", line 85, in synchronize\n    DebDeclarativeVersion(first_stage, repository, mirror=mirror).create()\n  File \"/var/pulp/pulpvenv/lib/python3.6/site-packages/pulpcore/plugin/stages/declarative_version.py\", line 169, in create\n    loop.run_until_complete(pipeline)\n  File \"/usr/lib/python3.6/asyncio/base_events.py\", line 484, in run_until_complete\n    return future.result()\n  File \"/var/pulp/pulpvenv/lib/python3.6/site-packages/pulpcore/plugin/stages/api.py\", line 209, in create_pipeline\n    await asyncio.gather(*futures)\n  File \"/var/pulp/pulpvenv/lib/python3.6/site-packages/pulpcore/plugin/stages/api.py\", line 43, in __call__\n    await self.run()\n  File \"/var/pulp/pulpvenv/lib/python3.6/site-packages/pulpcore/plugin/stages/artifact_stages.py\", line 217, in run\n    RemoteArtifact.objects.bulk_get_or_create(self._needed_remote_artifacts(batch))\n  File \"/var/pulp/pulpvenv/lib/python3.6/site-packages/pulpcore/plugin/stages/artifact_stages.py\", line 260, in _needed_remote_artifacts\n    c=d_content.content))\n"
    },
    "finished_at": "2019-08-30T20:32:54.387974Z",
    "name": "pulp_deb.app.tasks.synchronizing.synchronize",
    "non_fatal_errors": [],
    "parent": null,
    "progress_reports": [
        {
            "done": 1,
            "message": "Creating download requests for Release files",
            "state": "completed",
            "suffix": null,
            "total": 1
        },
        {
            "done": 1,
            "message": "Parsing Release files",
            "state": "completed",
            "suffix": null,
            "total": 1
        },
        {
            "done": 1,
            "message": "Parsing package index files",
            "state": "completed",
            "suffix": null,
            "total": 1
        },
        {
            "done": 0,
            "message": "Parsing installer file index files",
            "state": "completed",
            "suffix": null,
            "total": null
        },
        {
            "done": 3,
            "message": "Downloading Artifacts",
            "state": "completed",
            "suffix": null,
            "total": 3
        },
        {
            "done": 1,
            "message": "Update Release units",
            "state": "completed",
            "suffix": null,
            "total": 1
        },
        {
            "done": 1,
            "message": "Update PackageIndex units",
            "state": "completed",
            "suffix": null,
            "total": 1
        },
        {
            "done": 2,
            "message": "Associating Content",
            "state": "canceled",
            "suffix": null,
            "total": 2
        }
    ],
    "spawned_tasks": [],
    "started_at": "2019-08-30T20:32:54.106892Z",
    "state": "failed",
    "worker": "/pulp/api/v3/workers/de3a5ac3-caca-4540-8e8d-478fe7c59215/"
}

Now the relative to the URL passed into the remote, the repo is organized like:

$path/dists/bionic/Release
$path/dists/bionic/Release.gpg
$path/dists/bionic/main/binary-amd64/
$path/dists/bionic/main/binary-amd64/Packages{,.bz2,.gz}
$path/pool/
$path/pool/<debs here>

The package causing the error is chef-workstation which, in the packages file, has:

Package: chef-workstation
Version: 0.7.4-1
License: Chef EULA
Vendor: Omnibus <omnibus@getchef.com>
Architecture: amd64
Maintainer: Chef Software, Inc. <maintainers@chef.io>
Installed-Size: 605305
Conflicts: chefdk
Section: misc
Priority: extra
Homepage: https://chef.sh
Description: The full stack of chef-workstation
Filename: pool/chef-workstation_0.7.4-1_amd64.deb
SHA1: d7b46b3351ca610cb2894baab5304e5929b512c0
SHA256: fbb0c8e8f69692b273e180ba97c07609e4006e286b3a8db61ab5a5eb12a8d65c
Size: 131333094

And then is in:

pool/chef-workstation_0.7.4-1_amd64.deb

History

#1 Updated by jaymzh about 1 year ago

To be clear that last path is:

$path/pool/chef-workstation_0.7.4-1_amd64.deb

#2 Updated by mdellweg 12 months ago

Can you add some instructions to reproduce this?

#3 Updated by quba42 about 2 months ago

  • Status changed from NEW to CLOSED - NOTABUG

I am closing this issue, since it is not reproducible with the information provided, and there has been no response in 10 months.

If anyone thinks they are having this issue, please open a new issue with a full description of the API calls used to reproduce it.

Please register to edit this issue

Also available in: Atom PDF