Project

Profile

Help

Issue #527

gofer requires python-amqplib >= 1.0.2 which is not available on EL 6

Added by rbarlow over 6 years ago. Updated over 2 years ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
2.4.0
Platform Release:
2.6.0
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Description of problem:
[rbarlow@newspaper]~% sudo yum install python-gofer-amqplib
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* base: centos.aol.com
* epel: download-i2.fedoraproject.org
* extras: mirrors.advancedhosters.com
* updates: mirror.us.leaseweb.net
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package python-gofer-amqplib.noarch 0:1.3.0-1.el6 will be installed
--> Processing Dependency: python-amqplib >= 1.0.2 for package: python-gofer-amqplib-1.3.0-1.el6.noarch
--> Finished Dependency Resolution
Error: Package: python-gofer-amqplib-1.3.0-1.el6.noarch (pulp-2-stable)
Requires: python-amqplib >= 1.0.2
Available: python-amqplib-0.6.1-2.el6.noarch (epel)
python-amqplib = 0.6.1-2.el6
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Version-Release number of selected component (if applicable):
2.4.0-1

How reproducible:
Every time.

Steps to Reproduce:
1. On an EL 6 system, try to yum install python-gofer-amqplib

Actual results:
Missing dependencies.

Expected results:
It should install successfully.

+ This bug was cloned from Bugzilla Bug #1141920 +

History

#1 Updated by contact@andreagiardini.com over 6 years ago

Same problem here

+ This comment was cloned from Bugzilla #1141920 comment 1 +

#2 Updated by ashbyj@imsweb.com over 6 years ago

Same problem here as well. CentOS 6.5.

Found an rpm here and installed via yum: http://pkgs.org/centos-6/repoforge-i386/python-amqplib-1.0.2-1.el6.rf.noarch.rpm.html

Then I was able to yum install python-gofer-amqplib. I have not tested further at this time, just dropping a note here if it helps anyone.

+ This comment was cloned from Bugzilla #1141920 comment 2 +

#3 Updated by cduryee over 6 years ago

***** Bug 1087618 has been marked as a duplicate of this bug. ***

+ This comment was cloned from Bugzilla #1141920 comment 3 +

#4 Updated by jortel@redhat.com over 6 years ago

Gofer 1.4 provides python-gofer-amqp which works with the celery fork python-amqp that we provide. gofer 1.4 is already included in 2.6 alpha builds.

+ This comment was cloned from Bugzilla #1141920 comment 4 +

#5 Updated by cduryee over 6 years ago

fixed in pulp 2.6.0-0.2.beta

+ This comment was cloned from Bugzilla #1141920 comment 5 +

#6 Updated by pthomas@redhat.com over 6 years ago

verified
[root@ibm-x3550m3-07 ~]# sudo yum install python-gofer-amqp
Loaded plugins: product-id, security, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package python-gofer-amqp.noarch 0:2.4.0-1.el6 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
Package Arch Version Repository Size
================================================================================
Installing:
python-gofer-amqp noarch 2.4.0-1.el6 pulp-2.6-beta 49 k

Transaction Summary
================================================================================
Install 1 Package(s)

Total download size: 49 k
Installed size: 68 k
Is this ok [y/N]: y
Downloading Packages:
python-gofer-amqp-2.4.0-1.el6.noarch.rpm | 49 kB 00:00
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Installing : python-gofer-amqp-2.4.0-1.el6.noarch 1/1
Verifying : python-gofer-amqp-2.4.0-1.el6.noarch 1/1

Installed:
python-gofer-amqp.noarch 0:2.4.0-1.el6

Complete!
[root@ibm-x3550m3-07 ~]#

+ This comment was cloned from Bugzilla #1141920 comment 6 +

#7 Updated by bmbouter over 6 years ago

  • Severity changed from Medium to 2. Medium

#8 Updated by rbarlow over 6 years ago

  • Status changed from 6 to CLOSED - CURRENTRELEASE

#10 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF