Project

Profile

Help

Story #5159

closed

As a user, I can optionally validate and repair content at sync time

Added by ttereshc almost 5 years ago. Updated over 4 years ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

Motivation

There are situations when content in the storage needs to be repaired (while DB is fine and still contains all the data):
- file got corrupted for whatever reason
- file was removed from the storage by accident
- etc

Users need a way to solve those situations.

Solution

Introduce an option repair for the sync operation. It should be False by default.
When the repair option is enabled, in the QueryExistingArtifacts stage make sure that the sha256 checksum of content in the storage is the same as stored in the DB.


Related issues

Is duplicate of Pulp - Story #5613: As a user, I have an API based way to report and redownload (if possible) corrupted content on the file system for one repositoryCLOSED - CURRENTRELEASEmdellweg

Actions
Actions #1

Updated by ttereshc almost 5 years ago

  • Description updated (diff)
Actions #2

Updated by ttereshc over 4 years ago

  • Related to Story #5613: As a user, I have an API based way to report and redownload (if possible) corrupted content on the file system for one repository added
Actions #3

Updated by ttereshc over 4 years ago

  • Parent issue set to #5113
Actions #4

Updated by ttereshc over 4 years ago

  • Status changed from NEW to CLOSED - DUPLICATE
  • Parent issue deleted (#5113)
Actions #5

Updated by ttereshc over 4 years ago

  • Related to deleted (Story #5613: As a user, I have an API based way to report and redownload (if possible) corrupted content on the file system for one repository)
Actions #6

Updated by ttereshc over 4 years ago

  • Is duplicate of Story #5613: As a user, I have an API based way to report and redownload (if possible) corrupted content on the file system for one repository added
Actions #7

Updated by ttereshc over 4 years ago

This problem will be solved not during sync but as a separate API call, see #5613

Also available in: Atom PDF