Project

Profile

Help

Issue #5146

Docker sync missing schema version 1 manifests

Added by iballou over 2 years ago. Updated about 2 years ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Platform Release:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

I noticed that some schema version 1 manifests are missing in some cases. In syncing BusyBox there are some, but in syncing library/hello-world there are none. More details:

Create repo:

http POST http://localhost:24817/pulp/api/v3/repositories/ name=bar

(Save REPO_HREF)

Create remote:

http POST http://localhost:24817/pulp/api/v3/remotes/docker/docker/ name='library/hello-world' upstream_name='library/hello-world' url='https://registry-1.docker.io' policy='on_demand'

(Save REMOTE_HREF)

Sync:

http POST ':24817'$REMOTE_HREF'sync/' repository=$REPO_HREF`` mirror=False

Try to view schema v1 manifests:

http :24817/pulp/api/v3/content/docker/manifests/?repository_version_added=/pulp/api/v3/repositories/<id>/versions/1/ | jq -r '.results[] | select(.schema_version == 1)'

This query finds nothing. I am expecting to see two manifests.

I confirmed in Foreman with Pulp 2 that there are supposed to be two schema v1 manifests in library/hello-world. I also tried searching Pulp 3 for them by their digests and couldn't find them.


Related issues

Has duplicate Container Support - Story #4244: Convert manifest to schema1 when older clients are pulling by tagCLOSED - CURRENTRELEASE

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by iballou over 2 years ago

Syncing "m2mcttc/discovery" using the same steps above makes the issue a bit easier to see since there are fewer manifests. Pulp 3 returns 2 v2 manifests but there should also be 2 v1 manifests.

#2 Updated by iballou over 2 years ago

Just a clarification, I'm talking about image manifest version 2, but schemas 1 and 2

#3 Updated by ipanova@redhat.com over 2 years ago

  • Status changed from NEW to CLOSED - DUPLICATE

#4 Updated by ipanova@redhat.com over 2 years ago

  • Has duplicate Story #4244: Convert manifest to schema1 when older clients are pulling by tag added

#5 Updated by ipanova@redhat.com about 2 years ago

  • Project changed from Docker Support to Container Support

Please register to edit this issue

Also available in: Atom PDF