Project

Profile

Help

Issue #5078

Including a PR in a Travis build fails with 'pushd: not found'

Added by daviddavis over 1 year ago. Updated 12 months ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
High
Assignee:
-
Category:
-
Sprint/Milestone:
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Plugin Template
Sprint:
Sprint 55
Quarter:

Description

Example: https://travis-ci.org/pulp/pulp_file/jobs/553829203#L505-L508

Error:

.travis/before_install.sh: 49: .travis/before_install.sh: pushd: not found
fatal: not a git repository (or any of the parent directories): .git
fatal: not a git repository (or any of the parent directories): .git
.travis/before_install.sh: 52: .travis/before_install.sh: popd: not found

We think the problem is that Travis is using Ubuntu which has dash and push/popd are bash extensions.

Associated revisions

Revision 06541f8c View on GitHub
Added by gmbnomis over 1 year ago

Improve before_install.sh

  • Use bash and the more secure set -mveuo pipefail (as in other scripts)

  • Use shallow clones and shallow fetch to speed up the CI run (Especially pulpcore takes a long time to clone completely. We don't need any history when building in the CI.)

  • get rid of pushd/popd (bashism that is not needed here)

https://pulp.plan.io/issues/5078 fixes #5078

History

#1 Updated by daviddavis over 1 year ago

  • Tags Plugin Template added

#2 Updated by amacdona@redhat.com over 1 year ago

  • Priority changed from Normal to High
  • Triaged changed from No to Yes
  • Sprint set to Sprint 55

#3 Updated by gmbnomis over 1 year ago

  • Status changed from NEW to MODIFIED

#4 Updated by bmbouter 12 months ago

  • Sprint/Milestone set to 3.0.0

#5 Updated by bmbouter 12 months ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE

Please register to edit this issue

Also available in: Atom PDF