Project

Profile

Help

Task #5010

Travis fails when PRs are rebased and merged

Added by daviddavis over 1 year ago. Updated about 1 year ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
Category:
-
Sprint/Milestone:
Start date:
Due date:
% Done:

100%

Estimated time:
Platform Release:
Groomed:
No
Sprint Candidate:
No
Tags:
Plugin Template
Sprint:
Quarter:

Description

Failing Travis:

https://travis-ci.com/pulp/pulpcore/jobs/210048379#L904-L908

The cause is that sometimes HEAD^2 is undefined. Try this in pulpcore and you'll get the same problem:

git checkout 2ccdc7dc0135a62d37854caecf664232f9303dfe
git show HEAD^2 -s

We probably shouldn't rely on HEAD^2. Rather, it looks like Travis has a TRAVIS_COMMIT_MESSAGE we could maybe use.

Associated revisions

Revision 1beee2cd View on GitHub
Added by daviddavis over 1 year ago

HEAD^2 considered harmful

In certain cases, HEAD^2 can be undefined. Use git log --no-merges instead.

fixes #5010

History

#1 Updated by amacdona@redhat.com over 1 year ago

  • Tracker changed from Issue to Task
  • % Done set to 0
  • Tags Plugin Template added

#2 Updated by daviddavis over 1 year ago

  • Status changed from NEW to POST
  • Assignee set to daviddavis

#3 Updated by daviddavis over 1 year ago

  • Status changed from POST to MODIFIED
  • % Done changed from 0 to 100

#4 Updated by bmbouter about 1 year ago

  • Sprint/Milestone set to 3.0.0

#5 Updated by bmbouter about 1 year ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE

Please register to edit this issue

Also available in: Atom PDF