Project

Profile

Help

Story #4905

As a user, I can set download timeouts

Added by daviddavis over 1 year ago. Updated 3 days ago.

Status:
CLOSED - DUPLICATE
Priority:
Low
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
Groomed:
No
Sprint Candidate:
No
Tags:
Katello
Sprint:
Quarter:

Description

In Pulp 2, we allow users to configure timeouts for syncs and such. They can set a read timeout and connection timeout. We need this behavior in Pulp 3 as well.

See https://pulp.plan.io/issues/1758#note-17:

Currently we offer options like concurrency, but these would be good options also.

Also the current options can be seen here: https://docs.pulpproject.org/en/3.0/nightly/restapi.html#operation/remotes_file_file_create

Related issues

Is duplicate of Pulp - Story #7201: As a user I can set http connection timeout and read timeoutNEW

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by jsherril@redhat.com over 1 year ago

  • Tags Katello-P3 added
  • Tags deleted (Katello-P4)

#3 Updated by ggainey 6 months ago

  • Priority changed from Normal to Low

#4 Updated by ggainey 6 months ago

  • Tags Katello added
  • Tags deleted (Katello-P3)

#5 Updated by bmbouter 3 days ago

Closing as a duplicate of https://pulp.plan.io/issues/7201

#6 Updated by bmbouter 3 days ago

  • Status changed from NEW to CLOSED - DUPLICATE

#7 Updated by bmbouter 3 days ago

  • Is duplicate of Story #7201: As a user I can set http connection timeout and read timeout added

Please register to edit this issue

Also available in: Atom PDF