Project

Profile

Help

Issue #486

node deactivate does not remove the binding of the repo to the node

Added by pthomas@redhat.com over 5 years ago. Updated over 1 year ago.

Status:
CLOSED - WONTFIX
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
2.4 Beta
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Description of problem:

If you deactivate a repo that has has bound repo, seems like node deactivate does not remove the binding. So if you activate it again the repo stays bound. So node sync, syncs up the repo.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
[root@cloud-qe-15 ~]# pulp-admin node deactivate --node-id node1
Child node deactivated.

[root@cloud-qe-15 ~]#
[root@cloud-qe-15 ~]#
[root@cloud-qe-15 ~]# pulp-admin node activate --node-id node1
Command: activate
Description: activate a consumer as a child node

Available Arguments:

--consumer-id - (required) unique identifier; only alphanumeric, ., -, and _
                allowed
--strategy    - synchronization strategy (mirror|additive) default is additive
The following options were specified but do not exist on the command:
--node-id
[root@cloud-qe-15 ~]# pulp-admin node activate --consumer-id node1
Consumer activated as child node.

[root@cloud-qe-15 ~]# pulp-admin node sync run --node-id node1
This command may be exited via ctrl+c without affecting the request.

(1/2) Repository: copy
[==================================================] 100%

(2/2) Repository: upload
[==================================================] 100%

Synchronization succeeded

--------------------------------------------------------------------
Child Node Synchronization
--------------------------------------------------------------------

Repository:
Action: Merged
Content Sources:
Downloads:
Total Passes: 0
Total Sources: 0
Id: copy
Units:
Added: 0
Removed: 0
Updated: 0

Repository:
Action: Merged
Content Sources:
Downloads:
Total Passes: 0
Total Sources: 0
Id: upload
Units:
Added: 0
Removed: 0
Updated: 0

Repository:
Action: Removed
Content Sources:
Downloads:
Id: zoo
Units:
Added: 0
Removed: 0
Updated: 0

Actual results:

Expected results:

Additional info:

+ This bug was cloned from Bugzilla Bug #1128235 +

History

#1 Updated by jortel@redhat.com over 5 years ago

Given that nodes are activated by adding a special note on the consumer document, I don't believe this is a regression. Further, since the deactivation is a consumer update to the REST and manager layers, this would be hard to fix without doing a real hack. There have been discussion about making nodes a 1st class thing in the platform. I think this should be addressed properly then.

+ This comment was cloned from Bugzilla #1128235 comment 1 +

#2 Updated by bmbouter over 5 years ago

  • Severity changed from Medium to 2. Medium

#3 Updated by amacdona@redhat.com about 4 years ago

  • Status changed from NEW to CLOSED - WONTFIX

Closed because Pulp 3.0 will be dropping nodes support.

#4 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF