Project

Profile

Help

Story #4647

As a user, I can create a plugin specific publication using /pulp/api/v3/publications/<plugin>/ endpoint

Added by dkliban@redhat.com almost 2 years ago. Updated over 1 year ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
Groomed:
No
Sprint Candidate:
Yes
Tags:
Sprint:
Quarter:

Description

Plugin API Changes:

Convert Publication to a Master/Detail model.
Plugin writers implement their version of Publication which implements the 'create' method. The create method dispatches the same task that the current publishers dispatch. All attributes that plugin writers currently provide for a Publisher will now belong to a Publication.

REST API changes:

Each plugin will add a `/pulp/api/v3/publications/<plugin>/` to the REST API.

The Publishers API will be marked as deprecated and will be removed from the REST API in RC 3. (pulpcore 3.0.0rc3 and pulpcore-plugin 0.3.0rc3)


Related issues

Is duplicate of Pulp - Story #4678: As a plugin writer, I have Master/Detail PublicationsCLOSED - CURRENTRELEASE

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by dkliban@redhat.com almost 2 years ago

  • Description updated (diff)

#2 Updated by amacdona@redhat.com almost 2 years ago

  • Description updated (diff)

#3 Updated by dkliban@redhat.com almost 2 years ago

  • Is duplicate of Story #4678: As a plugin writer, I have Master/Detail Publications added

#4 Updated by dkliban@redhat.com almost 2 years ago

  • Status changed from NEW to CLOSED - DUPLICATE

#5 Updated by daviddavis almost 2 years ago

  • Sprint/Milestone set to 3.0.0

#6 Updated by bmbouter over 1 year ago

  • Tags deleted (Pulp 3)

Please register to edit this issue

Also available in: Atom PDF