Project

Profile

Help

Issue #458

User create lets you create a user without a password but login fails

Added by pthomas@redhat.com over 6 years ago. Updated over 2 years ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
1. Low
Version:
2.4 Beta
Platform Release:
2.7.0
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Description of problem:

A user can be created without any password but trying to login with that user fails.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Run pulp-admin auth login -u foo and hit enter
2. Hit enter for password and confirm password
3.Run pulp-admin login -u foo

Actual results:
[root@ibm-x3550m3-10 ~]# pulp-admin auth user create --login user2
Enter password for user [user2] :
Re-enter password for user [user2]:
User [user2] successfully created

[root@ibm-x3550m3-10 ~]# pulp-admin login -u user2
Enter password:
Authentication Failed

Use the login command to authenticate with the server and download a session
certificate for use in future calls to this script. If credentials were
specified, please double check the username and password and attempt the request
again.

Expected results:

Additional info:

+ This bug was cloned from Bugzilla Bug #1111591 +

History

#1 Updated by amacdona@redhat.com over 6 years ago

austin@laptop|/home/austin/code/pulp on 2.4-dev?
± pulp-admin auth user create --login user2
Enter password for user [user2] : <no input here>
Re-enter password for user [user2]: <no input here>
User [user2] successfully created

austin@laptop|/home/austin/code/pulp on 2.4-dev?
± pulp-admin login -u user2
Enter password: <no input here>
Successfully logged in. Session certificate will expire at Nov 13 15:40:47 2014
GMT.

Appears to be fixed in both 2.4-dev and 2.5-dev.

+ This comment was cloned from Bugzilla #1111591 comment 1 +

#2 Updated by igulina@redhat.com over 6 years ago

Failed QA

Austin, for you everything is OK, because I think you worked under valid certificate. My certificate was expired. Look what happened:

pulp-admin -u admin -p admin auth user create --login no_pass_user

Enter password for user [no_pass_user] : <enter>
Re-enter password for user [no_pass_user]: <enter>
User [no_pass_user] successfully created

pulp-admin login -u no_pass_user

Enter password:
Session Expired

The session certificate expired on Oct 24 14:51:22 2014 GMT.

date

Thu Nov 13 14:24:50 UTC 2014

pulp-admin login --username admin

Enter password: <admin pass>
Successfully logged in. Session certificate will expire at Nov 20 14:25:56 2014
GMT.

pulp-admin login --username no_pass_user

Enter password: <enter>
Successfully logged in. Session certificate will expire at Nov 20 14:26:03 2014
GMT.

...broken pipe

pulp-admin rpm repo list

--------------------------------------------------------------------
RPM Repositories
--------------------------------------------------------------------

Id: gena
Display Name: gena
Description: None
Content Unit Counts:
Rpm: 2

Id: m1
Display Name: m1
Description: None
Content Unit Counts:

pulp-admin logout

Session certificate successfully removed.

pulp-admin rpm repo list

--------------------------------------------------------------------
RPM Repositories
--------------------------------------------------------------------

The specified user does not have permission to execute the given command

pulp-admin login -u no_pass_user

Enter password:
The specified user does not have permission to execute the given command

pulp-admin -u admin -p admin auth user create --login funtik

Enter password for user [funtik] : <enter>
Re-enter password for user [funtik]: <enter>
User [funtik] successfully created

pulp-admin login -u funtik

Enter password: <enter>
The specified user does not have permission to execute the given command

rpm -qa | grep pulp-server

pulp-server-2.5.0-0.18.rc.fc20.noarch

+ This comment was cloned from Bugzilla #1111591 comment 2 +

#4 Updated by cduryee over 6 years ago

Setting BZ back to ASSIGNED, PR is still in WIP state.

+ This comment was cloned from Bugzilla #1111591 comment 4 +

#6 Updated by bmbouter over 6 years ago

  • Severity changed from Low to 1. Low

#7 Updated by dkliban@redhat.com over 6 years ago

  • Platform Release set to 2.7.0

#8 Updated by dkliban@redhat.com over 6 years ago

  • Status changed from MODIFIED to 5

#9 Updated by igulina@redhat.com over 6 years ago

  • Status changed from 5 to 6
>> rpm -qa pulp-server
pulp-server-2.7.0-0.3.beta.fc20.noarch

>> pulp-admin -u admin -p admin auth user create --login no_pass_user
Enter password for user [no_pass_user] : 
Re-enter password for user [no_pass_user]: 

Password cannot be empty

>> pulp-admin -u admin -p admin  auth user update --login no_pass_user -p
Enter password for user [no_pass_user] : 
Re-enter password for user [no_pass_user]: 

Password cannot be empty

#10 Updated by amacdona@redhat.com almost 6 years ago

  • Status changed from 6 to CLOSED - CURRENTRELEASE

#12 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF