Project

Profile

Help

Issue #4426

JSON serialization of schema fails with internal server error

Added by mdellweg over 1 year ago. Updated about 2 months ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Category:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:

Description

http --json :8000/pulp/api/v3/

returns

HTTP/1.1 500 Internal Server Error

The output of 'pulp-manage runserver' reveals the error to be:

AttributeError: 'dict' object has no attribute 'title'

I suspect this line: https://github.com/pulp/pulp/blob/5a938d8516b71aca6806b89f2cb80e3fda180f94/pulpcore/app/openapigenerator.py#L92
to return the wrong data type (at least, it does not match with the docstring).

Without '--json', valid yaml content seems to be created.


Related issues

Is duplicate of Pulp - Issue #4323: /pulp/api/v3/ returns 500 errorCLOSED - CURRENTRELEASE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by daviddavis over 1 year ago

  • Is duplicate of Issue #4323: /pulp/api/v3/ returns 500 error added

#2 Updated by daviddavis over 1 year ago

  • Status changed from NEW to CLOSED - DUPLICATE

#3 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

#4 Updated by Milesmsksth about 2 months ago

I was into this issue and tired to tinker around to check if its possible but couldnt get it done. Now that i have seen the way you did it, thanks guys with regards

https://kodi.software/

Please register to edit this issue

Also available in: Atom PDF