Project

Profile

Help

Story #4407

closed

[RFE] Maven plugin for pulp3

Added by jcpunk almost 4 years ago. Updated over 3 years ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

Pulp3 has support for a number of resources. Any chance a maven plugin could be added to pulp3 so I can sync Java resources?

This might also help with the JBoss folks....


Related issues

Is duplicate of Maven Plugin - Story #4183: As a user, I can use Pulp as a pull through cache for Maven CentralCLOSED - CURRENTRELEASEdkliban@redhat.com

Actions
Actions #1

Updated by amacdona@redhat.com almost 4 years ago

Some planning has already taken place for this plugin. https://pulp.plan.io/projects/pulp/wiki/Maven_Plugin

I have a very limited understanding, but AFAIK the maven plugin will require some arbitrarily deep nested content discovery, ie, a sync will download some content and discover it needs to download more content, repeat. This is a pattern that is slightly different than any of the current pulp 3 plugins, so it would be nice to get started on this soon to prove that it will work with the plugin API.

Actions #2

Updated by CodeHeeler almost 4 years ago

  • Tracker changed from Issue to Story
  • % Done set to 0
Actions #3

Updated by dkliban@redhat.com over 3 years ago

  • Is duplicate of Story #4183: As a user, I can use Pulp as a pull through cache for Maven Central added
Actions #4

Updated by dkliban@redhat.com over 3 years ago

  • Status changed from NEW to CLOSED - DUPLICATE
Actions #5

Updated by daviddavis over 3 years ago

  • Sprint/Milestone set to 3.0.0
Actions #6

Updated by bmbouter over 3 years ago

  • Tags deleted (Pulp 3)

Also available in: Atom PDF