Project

Profile

Help

Issue #4335

DNF can't handle empty modules.yaml.gz

Added by mono2stereo almost 3 years ago. Updated over 2 years ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
CentOS 7
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

DNF fails to synchronize cache for synced repositories.

## On server1:
$ pulp-admin rpm repo create --repo-id=ius-stable-el7 --feed=https://dl.iuscommunity.org/pub/ius/stable/CentOS/7/x86_64/ --relative-url=ius-stable-el7
Successfully created repository [ius-stable-el7]

$ pulp-admin rpm repo sync run --repo-id=ius-stable-el7
<< snip >>

## At client:
$ cat /etc/yum.repos.d/ius.repo
[ius-stable-el7]
name=ius-stable-el7
baseurl=https://server2/pulp/repos/ius-stable-el7/
enabled=1
skip_if_unavailable=0
gpgcheck=0

# dnf -v update
DNF version: 2.7.5
cachedir: /var/cache/dnf
<< snip >>
Cannot download 'https://server2/pulp/repos/ius-stable-el7/': Yum repo downloading error: Downloading error(s): repodata/f9cabc6ee185c75cf81c6b5eb6fc62a7d32e41b02bce2c5d9ad42935ecd112df-modules.yaml.gz - Cannot download, all mirrors were already tried without success.
Error: Failed to synchronize cache for repo 'ius-stable-el7'

Same on fedora28/29 and centos 7 clients.

The apache log of server2 shows that *-models.yaml.gz was returned with HTTP 200.
models.yaml is empty, tho. The feed has no models file at all.

# Server1:
$ uname -a
Linux server1 3.10.0-862.14.4.el7.x86_64 #1 SMP Wed Sep 26 15:12:11 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
$ rpm -qa | grep pulp
python-pulp-puppet-common-2.18.0-1.el7.noarch
python-pulp-deb-common-1.8.0-1.el7.noarch
python-pulp-bindings-2.18.0-2.el7.noarch
python-pulp-python-common-2.0.3-1.el7.noarch
python-pulp-repoauth-2.18.0-2.el7.noarch
python-pulp-agent-lib-2.18.0-2.el7.noarch
pulp-python-plugins-2.0.3-1.el7.noarch
pulp-puppet-tools-2.18.0-1.el7.noarch
python-pulp-oid_validation-2.18.0-2.el7.noarch
python-pulp-rpm-common-2.18.0-1.el7.noarch
python-pulp-docker-common-3.2.2-1.el7.noarch
pulp-deb-plugins-1.8.0-1.el7.noarch
python-pulp-client-lib-2.18.0-2.el7.noarch
pulp-docker-admin-extensions-3.2.2-1.el7.noarch
python-pulp-ostree-common-1.3.1-1.el7.noarch
pulp-python-admin-extensions-2.0.3-1.el7.noarch
pulp-server-2.18.0-2.el7.noarch
python-pulp-common-2.18.0-2.el7.noarch
pulp-rpm-admin-extensions-2.18.0-1.el7.noarch
pulp-ostree-plugins-1.3.1-1.el7.noarch
python-pulp-streamer-2.18.0-2.el7.noarch
pulp-selinux-2.18.0-2.el7.noarch
pulp-admin-client-2.18.0-2.el7.noarch
pulp-rpm-plugins-2.18.0-1.el7.noarch

Related issues

Is duplicate of RPM Support - Issue #4253: modules.yaml reference in repomd.xml does not use selected checksumCLOSED - CURRENTRELEASE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by mono2stereo almost 3 years ago

There is no issue when using yum.

#2 Updated by dalley almost 3 years ago

I was able to successfully reproduce this, and I was also able to verify that the patch mentioned in IRC does indeed fix it. On further review, it's probably not because the modules archive was empty, though -- it's more likely because of this separate bug which was fixed in the same patch:

https://pulp.plan.io/issues/4253

#3 Updated by dalley almost 3 years ago

  • Status changed from NEW to CLOSED - DUPLICATE

#4 Updated by dalley almost 3 years ago

  • Is duplicate of Issue #4253: modules.yaml reference in repomd.xml does not use selected checksum added

#5 Updated by dalley almost 3 years ago

Thank you for the report, mono2stereo!

The 2.18.1 beta release is scheduled for January 28. Until then, if you're not able to apply the patch manually, the simplest resolution would be to use yum on CentOS instead of dnf.

#6 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF