Project

Profile

Help

Issue #4317

AttributeError: 'RpmRemote' object has no attribute 'connection_limit'

Added by alexandreC 9 months ago. Updated 6 months ago.

Status:
NEW
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Severity:
2. Medium
Version:
Platform Release:
Blocks Release:
OS:
Backwards Incompatible:
No
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
QA Contact:
Complexity:
Smash Test:
Verified:
No
Verification Required:
No
Sprint:

Description

Hi, I'm currently trying to use pulp 3 with the RPM plugin, and I'm facing a problem when I follow the workflows. After creating the repo and the remote, I want to sync the repo, and the API returns the task, and nothing happens. After checking the logs an error has occurred

Jan 14 11:06:19 localhost.localdomain rq15377: File "pulpvenv/lib64/python3.6/site-packages/pulpcore/plugin/models/remote.py", line 61, in get_downloader
Jan 14 11:06:19 localhost.localdomain rq15377: return self.download_factory.build(url, **kwargs)
Jan 14 11:06:19 localhost.localdomain rq15377: File "pulpvenv/lib64/python3.6/site-packages/pulpcore/plugin/models/remote.py", line 42, in download_factory
Jan 14 11:06:19 localhost.localdomain rq15377: self._download_factory = DownloaderFactory(self)
Jan 14 11:06:19 localhost.localdomain rq15377: File "pulpvenv/lib64/python3.6/site-packages/pulpcore/plugin/download/factory.py", line 67, in init
Jan 14 11:06:19 localhost.localdomain rq15377: self._semaphore = asyncio.Semaphore(value=remote.connection_limit)
Jan 14 11:06:19 localhost.localdomain rq15377: AttributeError: 'RpmRemote' object has no attribute 'connection_limit'
Jan 14 11:06:19 localhost.localdomain rq15377: pulp: rq.worker:WARNING: Moving job to 'failed' queue
Jan 14 11:06:19 localhost.localdomain rq15377: pulp: rq.worker:INFO: : pulpcore.tasking.tasks._release_resources('1faacd76-dc8a-4b4a-a772-11313f...-902785495358)
Jan 14 11:06:19 localhost.localdomain rq15377: pulp: rq.worker:INFO: : Job OK (546f5a9f-f4b1-4498-b494-902785495358)

Has anyone had this issue before?

History

#1 Updated by ttereshc 9 months ago

Please, provide which versions of the core and plugins you are using. The result of the GET request to the status endpoint would be helpful.
E.g.

 $ http http://your_pulp_host.com/pulp/api/v3/status/

#2 Updated by ttereshc 9 months ago

  • Project changed from Pulp to RPM Support
  • Subject changed from RPM Pluggin pulp 3 to AttributeError: 'RpmRemote' object has no attribute 'connection_limit'
  • Category deleted (API)
  • Sprint/Milestone deleted (3.0)

#3 Updated by alexandreC 9 months ago


{
    "database_connection": {
        "connected": true
    },
    "missing_workers": [],
    "online_workers": [
        {
            "_created": "2019-01-13T15:31:22.620755Z",
            "_href": "/pulp/api/v3/workers/3/",
            "last_heartbeat": "2019-01-14T19:20:20.909877Z",
            "missing": false,
            "name": "reserved_resource_worker_2@localhost.localdomain",
            "online": true
        },
        {
            "_created": "2019-01-11T23:24:47.646711Z",
            "_href": "/pulp/api/v3/workers/1/",
            "last_heartbeat": "2019-01-14T19:20:20.909578Z",
            "missing": false,
            "name": "resource_manager@localhost.localdomain",
            "online": true
        },
        {
            "_created": "2019-01-11T23:25:28.409862Z",
            "_href": "/pulp/api/v3/workers/2/",
            "last_heartbeat": "2019-01-14T19:20:22.766748Z",
            "missing": false,
            "name": "reserved_resource_worker_1@localhost.localdomain",
            "online": true
        }
    ],
    "redis_connection": {
        "connected": true
    },
    "versions": [
        {
            "component": "pulpcore",
            "version": "3.0.0b18" 
        },
        {
            "component": "pulpcore-plugin",
            "version": "0.1.0b13" 
        },
        {
            "component": "pulp_rpm",
            "version": "3.0.0b1" 
        }
    ]
}

#4 Updated by ttereshc 9 months ago

Can you, please, try to downgrade to previous beta for pulpcore https://pypi.org/project/pulpcore/3.0.0b17/ ?
It should help.
And we'll make sure we pin the compatible versions properly.
Thank you!

#5 Updated by ttereshc 9 months ago

  • Project changed from RPM Support to Pulp

#6 Updated by CodeHeeler 9 months ago

  • Triaged changed from No to Yes

#7 Updated by bmbouter 6 months ago

  • Tags deleted (Pulp 3)

Please register to edit this issue

Also available in: Atom PDF