Project

Profile

Help

Issue #4251

Hard-Coded timeout causing issues with search on RHCC

Added by jmontleo@redhat.com about 1 year ago. Updated 10 months ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Severity:
2. Medium
Version - Crane:
master
Platform Release:
Blocks Release:
Target Release - Crane:
OS:
Backwards Incompatible:
No
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
QA Contact:
Complexity:
Smash Test:
Verified:
No
Verification Required:
No
Sprint:

Description

Ansible Service Broker (a.k.a Automation Broker) depends on being able to run a search query against RHCC. That search sometimes returns no results.

It sounds as though we're bumping up against a timeout that is hard coded:

"Upstream Crane has a hard-coded 1 second timeout for search. So, if Solr takes longer than 1 second to respond, Crane will return a 503 back to the client."

https://github.com/pulp/crane/blob/5a34c2980999012cded4c17105e9e4a515fc2308/crane/search/base.py#L101

History

#1 Updated by peasters about 1 year ago

This is a duplicate of #3706

#2 Updated by jmontleo@redhat.com about 1 year ago

  • Status changed from NEW to CLOSED - DUPLICATE

#3 Updated by bmbouter 10 months ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF