Project

Profile

Help

Story #4235

closed

pulpcore-plugin version should be showed in status API

Added by rochacbruno about 4 years ago. Updated over 2 years ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
Category:
-
Sprint/Milestone:
Start date:
Due date:
% Done:

100%

Estimated time:
Platform Release:
3.0.0
Groomed:
No
Sprint Candidate:
No
Tags:
Easy Fix
Sprint:
Quarter:

Description

When requesting /status API we see the version for pulpcore and all the plugins but the new pulpcore-plugin component is missing there.

Current Results

pulpcore-plugin is not present

$ http http://HOST/pulp/api/v3/status/
HTTP/1.1 200 OK

{
    ...
    "versions": [
        {
            "component": "pulpcore",
            "version": "3.0.0b16"
        },
        {
            "component": "pulp_docker",
            "version": "4.0a1.dev1"
        },
        {
            "component": "pulp_rpm",
            "version": "3.0.0b1"
        },
        {
            "component": "pulp_file",
            "version": "0.0.1b6"
        },
        {
            "component": "pulp_python",
            "version": "3.0.0b3"
        }
    ]
}

Expected Results

pulpcore-plugin is showed

$ http http://HOST/pulp/api/v3/status/
HTTP/1.1 200 OK

{
    ...
    "versions": [
        {
            "component": "pulpcore",
            "version": "3.0.0b16"
        },
        {
            "component": "pulpcore-plugin",
            "version": "0.1.0b14"
        },
        {
            "component": "pulp_docker",
            "version": "4.0a1.dev1"
        },
        {
            "component": "pulp_rpm",
            "version": "3.0.0b1"
        },
        {
            "component": "pulp_file",
            "version": "0.0.1b6"
        },
        {
            "component": "pulp_python",
            "version": "3.0.0b3"
        }
    ]
}

Also available in: Atom PDF