Project

Profile

Help

Issue #418

pulp does not start if no plugins that place a file in /etc/pulp/vhosts80 are installed

Added by mkovacik@redhat.com over 5 years ago. Updated over 1 year ago.

Status:
CLOSED - DUPLICATE
Priority:
High
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
2.4 Beta
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Easy Fix, Pulp 2
Sprint:
Quarter:

Description

Description of problem:
Updating from Alpha I've encountered a syntax error in `/etc/httpd/conf.d/pulp.conf`
It seems to be caused by the wildcard not being able to match anything in the target directory of the Include statement:
# line53
<VirtualHost :80>
Include /etc/pulp/vhosts80/
.conf
</VirtualHost>

A simple workaround is to create a dummy config file:
sudo touch /etc/pulp/vhosts80/empty.conf

Version-Release number of selected component (if applicable):
pulp-server-2.4.0-0.9.beta.git.71.8eb429a.fc20.noarch

How reproducible:
Always

Steps to Reproduce:
1. install pulp-server
2. systemctl restart httpd.service

Actual results:

  1. service fails to start due to config file "syntax" error:
    [buildbot@dhcp131-12 workdir]$ sudo systemctl status httpd.service
    httpd.service - The Apache HTTP Server
    Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled)
    Active: failed (Result: exit-code) since Thu 2014-04-24 05:10:42 EDT; 3min 39s ago
    Process: 11297 ExecStop=/bin/kill -WINCH ${MAINPID} (code=exited, status=0/SUCCESS)
    Process: 11294 ExecStart=/usr/sbin/httpd $OPTIONS -DFOREGROUND (code=exited, status=1/FAILURE)
    Main PID: 11294 (code=exited, status=1/FAILURE)
    Status: "Total requests: 0; Current requests/sec: 0; Current traffic: 0 B/sec"

Apr 24 05:10:42 dhcp131-12.brq.redhat.com systemd[1]: Starting The Apache HTTP Server...
Apr 24 05:10:42 dhcp131-12.brq.redhat.com httpd[11294]: httpd: Syntax error on line 353 of /etc/httpd/conf/httpd.conf: Syntax error on line 54 of /etc/httpd/conf.d/pulp.conf: No matches for the wildcard '*.conf' in '/e...nal if required)
Apr 24 05:10:42 dhcp131-12.brq.redhat.com systemd[1]: httpd.service: main process exited, code=exited, status=1/FAILURE
Apr 24 05:10:42 dhcp131-12.brq.redhat.com systemd[1]: Failed to start The Apache HTTP Server.
Apr 24 05:10:42 dhcp131-12.brq.redhat.com systemd[1]: Unit httpd.service entered failed state.
Hint: Some lines were ellipsized, use -l to show in full.

Expected results:

  1. httpd service ok to start

Additional info:

+ This bug was cloned from Bugzilla Bug #1090835 +


Related issues

Is duplicate of Pulp - Issue #293: Apache Complains On Missing Pulp ModulesCLOSED - CURRENTRELEASE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by mhrivnak over 5 years ago

This is a known issue that is only a problem if no plugins are installed, in which case pulp isn't useful.

+ This comment was cloned from Bugzilla #1090835 comment 1 +

#2 Updated by rbarlow about 5 years ago

  • Subject changed from pulp does not start if no plugins are installed to pulp does not start if no plugins that place a file in /etc/pulp/vhosts80 are installed
  • Priority changed from Low to High
  • Severity set to 2. Medium
  • Triaged changed from Yes to No

This error actually happens if only pulp_docker is installed because it does not install a file to /etc/pulp/vhosts80, so I think it's severity should be raised.

I'm untriaging it so that the triage team can reconsider it.

#3 Updated by bcourt about 5 years ago

  • Triaged changed from No to Yes
  • Tags Easy Fix added

pulp-server should include a file here that does nothing so the directive will be valid.

#4 Updated by jcline@redhat.com almost 5 years ago

  • Status changed from NEW to CLOSED - DUPLICATE

This is a duplicate of https://pulp.plan.io/issues/293

#5 Updated by jcline@redhat.com almost 5 years ago

  • Is duplicate of Issue #293: Apache Complains On Missing Pulp Modules added

#6 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF