Project

Profile

Help

Task #4003

Uncouple pulpcore tests from plugins by creating a test plugin

Added by daviddavis about 2 years ago. Updated about 2 months ago.

Status:
CLOSED - WONTFIX
Priority:
Normal
Assignee:
-
Category:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
Groomed:
No
Sprint Candidate:
No
Tags:
Functional Test
Sprint:
Quarter:

Description

Some of pulpcore tests rely on the pulp_file[0] and pulp_rpm[1] plugins. The problem is that this won't scale. As we add more features to pulpcore that are only used by a subset of plugins, this design will require us to install more plugins into pulpcore's CI.

We should decouple pulpcore tests from requiring plugins by introducing a test plugin that tests can use. This test plugin would contain a superset of all features that pulpcore provides.

Alternatively we could maybe leverage the plugin template to be this test plugin.

[0] https://github.com/pulp/pulpcore/tree/master/pulpcore/tests/functional/api/using_plugin
[1] https://github.com/pulp/pulpcore/blob/master/pulpcore/tests/functional/api/using_plugin/test_sync_multiple_plugins.py

History

#1 Updated by amacdona@redhat.com almost 2 years ago

Since the plugin_template includes tests, it would be really convenient if we use that.

#2 Updated by bmbouter almost 2 years ago

How do you imagine the TestPlugin working? Would it actually sync and publish content?

#3 Updated by bmbouter over 1 year ago

  • Tags deleted (Pulp 3)

#4 Updated by daviddavis over 1 year ago

  • Subject changed from Uncouple the pulpcore tests from pulp_file by creating a TestPlugin to Uncouple pulpcore tests from plugins by creating a test plugin
  • Description updated (diff)

#5 Updated by daviddavis about 2 months ago

  • Status changed from NEW to CLOSED - WONTFIX

Please register to edit this issue

Also available in: Atom PDF