Project

Profile

Help

Task #3942

closed

Story #3202: As a user, I can sync RPM/SRPM/Erratum from a remote Yum/DNF repository

Store a digest of the fields for an UpdateRecord

Added by daviddavis over 5 years ago. Updated about 2 years ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

Ticket moved to GitHub: "pulp/pulp_rpm/2208":https://github.com/pulp/pulp_rpm/issues/2208


Currently, we have a digest field that captures a hash digest of the update record's xml. The problem is that this is very fragile and could change based on stuff like whitespace or character encoding.

Solution

Instead, store the hash digest of UpdateRecord's fields along with the its UpdateCollections and UpdateCollectionPackages. using a detereministic data structure like an ordered dictionary.

Also available in: Atom PDF