Project

Profile

Help

Story #3727

Story #3716: As a production Pulp user, I have an Ansible installer

Story #3719: Create the webserver role

As a role user, I can have Nginx installed and configured to serve Pulp

Added by bmbouter over 2 years ago. Updated 5 months ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
-
Category:
Installer
Sprint/Milestone:
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

This should configure nginx to serve all Pulp wsgi applications to be served via /.

The documentation on how to deploy Pulp's webserver are here: https://docs.pulpproject.org/en/3.0/nightly/overview/components/webserver.html

It should install the systemd files for nginx.


Related issues

Is duplicate of Pulp - Task #2921: Create and publish an ansible role to install apache and configure it for pulpCLOSED - WONTFIX

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by bmbouter over 2 years ago

  • Parent task changed from #3716 to #3719

#2 Updated by dkliban@redhat.com over 2 years ago

Shouldn't this role have options to enable REST API and Content App?

There is a use case where you want to only expose just the REST API or just the Content App.

#3 Updated by bmbouter over 2 years ago

It should have that but we were going to add that later. Also there is an option for live APIs as well that we need to consider.

What do you think about that?

#4 Updated by amacdona@redhat.com over 2 years ago

  • Is duplicate of Task #2921: Create and publish an ansible role to install apache and configure it for pulp added

#5 Updated by amacdona@redhat.com over 2 years ago

  • Status changed from NEW to CLOSED - WONTFIX

This story has been split, each of the new stories is marked as a duplicate.

#6 Updated by amacdona@redhat.com over 2 years ago

  • Status changed from CLOSED - WONTFIX to NEW

#7 Updated by amacdona@redhat.com about 2 years ago

  • Status changed from NEW to MODIFIED

#8 Updated by daviddavis over 1 year ago

  • Sprint/Milestone set to 3.0.0

#9 Updated by bmbouter over 1 year ago

  • Tags deleted (Pulp 3)

#10 Updated by bmbouter 10 months ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE

#11 Updated by bmbouter 5 months ago

  • Category set to Installer
  • Tags deleted (Pulp 3 installer)

Please register to edit this issue

Also available in: Atom PDF