Project

Profile

Help

Issue #370

Updating consumer groups

Added by chase.whitener@infotechfl.com almost 7 years ago. Updated over 2 years ago.

Status:
CLOSED - NOTABUG
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Master
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Description of problem:
We have a few consumers setup (CentOS). We are able to update the individual consumers without error. We grouped several like consumers together into a consumer group and tried to update the consumer group together. That fails and appears to be a bug in how the CLI is parsing the data it gets back from the server.

Version-Release number of selected component (if applicable):

How reproducible: Very. Every time.

Steps to Reproduce:
1. pulp-admin rpm consumer group package update --consumer-group-id=it-nonprod --names='*'
"An unexpected error has occurred. More information can be found in the client
log file ~/.pulp/admin.log."
Consumer logs show nothing on the consumers in the group. Gopher logs show that responses are being sent.

Actual results:
2013-09-06 10:27:51,241 - ERROR - Client-side exception occurred
Traceback (most recent call last):
File "/usr/lib/python2.6/site-packages/pulp/client/extensions/core.py", line 478, in run
exit_code = Cli.run(self, args)
File "/usr/lib/python2.6/site-packages/okaara/cli.py", line 966, in run
exit_code = command_or_section.execute(self.prompt, remaining_args)
File "/usr/lib/python2.6/site-packages/pulp/client/extensions/extensions.py", line 224, in execute
return self.method(*arg_list, **clean_kwargs)
File "/usr/lib/pulp/admin/extensions/rpm_admin_consumer/consumer_group_package.py", line 183, in run
self.update(consumer_group_id, units, options)
File "/usr/lib/pulp/admin/extensions/rpm_admin_consumer/consumer_group_package.py", line 195, in update
msg = _('Update task created with id [%s]') % task.task_id
AttributeError: 'list' object has no attribute 'task_id'

Expected results:
Expected it to attempt to update all consumers in the consumer group

+ This bug was cloned from Bugzilla Bug #1005263 +


Related issues

Related to Pulp - Issue #722: Consumer Groups CLI is not documentedCLOSED - CURRENTRELEASE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by chase.whitener@infotechfl.com almost 7 years ago

I downgraded the severity as more testing shows that the updates are actually happening on the client ends.

What's failing is the pulp-admin application.

pulp-admin rpm consumer group package update --consumer-group-id=it-nonprod --names='*'

That command properly sets up the different tasks and they run, however, when the command waits for a response from the servers, it treats that response as if it's one singular response when it's a list of responses (Tasks). So, as it tries to get the task_id, it fails because it's asking a list for a property instead of the first element in the list for that property.

pulp-admin tasks list

That command properly shows the tasks moving along to completion.

+ This comment was cloned from Bugzilla #1005263 comment 1 +

#2 Updated by amacdona@redhat.com almost 7 years ago

  • Status changed from NEW to 7

When I ran the command specified:

@pulp-admin rpm consumer group package update --consumer-group-id=it-nonprod --names='*'@

I am warned that --names is not a valid option. Running the same command except using --name='*', this issues the correct call to the server, though I do not think that wildcards are supported here.

I am closing this bug, please reopen if you think there is a continuing problem here.This does however highlight that there is not any documentation for this portion of our CLI,and I have created a new issue for that. https://pulp.plan.io/issues/722

#3 Updated by bmbouter over 6 years ago

  • Related to Issue #722: Consumer Groups CLI is not documented added

#4 Updated by bmbouter over 6 years ago

  • Status changed from 7 to CLOSED - NOTABUG

#5 Updated by bmbouter over 6 years ago

  • Severity changed from Medium to 2. Medium

#6 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF