Project

Profile

Help

Issue #367

closed

References to old collection names and content_unit_count needs to be updated in API docs

Added by skarmark@redhat.com about 7 years ago. Updated about 3 years ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
1. Low
Version:
Master
Platform Release:
2.6.0
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Documentation, Pulp 2
Sprint:
Quarter:

Description

Content_unit_count is now a dictionary and is renamed to content_unit_counts. It should be updated in the examples of our rest API docs.

$ grep -r "content_unit_count" rest-api/*
rest-api/repo/retrieval.rst: "content_unit_count": 0,
rest-api/repo/retrieval.rst: "content_unit_count": 0,
rest-api/repo/retrieval.rst: "content_unit_count": 0,
rest-api/repo/retrieval.rst: "content_unit_count": 0,
rest-api/repo/cud.rst: "content_unit_counts": {},
rest-api/repo/cud.rst: "content_unit_counts": {},

There are also a lot of references to old collection names "gc_repo_importers", "gc_repos" etc.

$ grep -r "gc_" rest-api/*
rest-api/consumer/retrieval.rst: "_ns": "gc_consumers",
rest-api/consumer/retrieval.rst: "_ns": "gc_consumers",
rest-api/consumer/retrieval.rst: "_ns": "gc_consumers",
rest-api/consumer/retrieval.rst: "_ns": "gc_consumers",
rest-api/consumer/retrieval.rst: "_ns": "gc_consumers",
rest-api/consumer/retrieval.rst: "_ns": "gc_consumers",
rest-api/consumer/retrieval.rst: "_ns": "gc_consumers",
rest-api/consumer/history.rst: "_ns": "gc_consumer_history",
rest-api/consumer/history.rst: "_ns": "gc_consumer_history",
rest-api/consumer/cud.rst: "_ns": "gc_consumers",
rest-api/consumer/cud.rst: "_ns": "gc_consumers",
rest-api/repo/retrieval.rst: "_ns": "gc_repo_distributors",
rest-api/repo/retrieval.rst: "_ns": "gc_repo_importers",
rest-api/repo/retrieval.rst: "_ns": "gc_repo_distributors",
rest-api/repo/retrieval.rst: "_ns": "gc_repo_importers",
rest-api/repo/retrieval.rst: "_ns": "gc_repo_distributors",
rest-api/repo/retrieval.rst: "_ns": "gc_repo_importers",
rest-api/repo/retrieval.rst: "_ns": "gc_repo_distributors",
rest-api/repo/retrieval.rst: "_ns": "gc_repo_importers",
rest-api/repo/retrieval.rst: "_ns": "gc_repo_importers",
rest-api/repo/retrieval.rst: "_ns": "gc_repo_distributors",
rest-api/repo/cud.rst: "_ns": "gc_repo_importers",
rest-api/repo/cud.rst: "_ns": "gc_repo_distributors",

+ This bug was cloned from Bugzilla Bug #1004623 +

Actions #1

Updated by cduryee about 7 years ago

This is still outstanding as of Pulp 2.4.3.

+ This comment was cloned from Bugzilla #1004623 comment 1 +

Actions #2

Updated by cduryee about 7 years ago

***** Bug 767635 has been marked as a duplicate of this bug. ***

+ This comment was cloned from Bugzilla #1004623 comment 2 +

Actions #4

Updated by cduryee about 7 years ago

PR has been merged to 2.6-dev and master, setting state to MODIFIED.

+ This comment was cloned from Bugzilla #1004623 comment 4 +

Actions #5

Updated by cduryee about 7 years ago

fixed in pulp 2.6.0-0.2.beta

+ This comment was cloned from Bugzilla #1004623 comment 5 +

Actions #7

Updated by bmbouter about 7 years ago

  • Category deleted (1)
  • Tags Documentation added

Documentation is now a Tag not a Category.

Actions #8

Updated by bmbouter about 7 years ago

  • Severity changed from Low to 1. Low
Actions #9

Updated by rbarlow about 7 years ago

  • Status changed from 6 to CLOSED - CURRENTRELEASE
Actions #11

Updated by bmbouter about 3 years ago

  • Tags Pulp 2 added

Also available in: Atom PDF