Project

Profile

Help

Story #3402

closed

As a user I can add Manifests to a repository, and any Blobs that are a part of them

Added by amacdona@redhat.com almost 5 years ago. Updated about 3 years ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

This story will be complete when a user can add one or many Manifests to a repository, and the blobs referenced by each manifest are also added to the repository.

This story falls under the category of "rich copy" and will need a new API endpoint.

Before this story is groomed we should determine where that endpoint will live. If this recursive copy needs any importer settings it would make sense to be a detail route (like sync) on the importer.

 v3/importers/docker/1234/fancy_pants_add/

If not, we would have to come up with somewhere else. In theory, we can register a new ViewSet wherever we want, so I'd recommend starting with a docker namespace.

/v3/docker/recursive_add/

Related issues

Is duplicate of Container Support - Story #3403: As a user I can add Manifests to a repository, and all units (recursive) that are part of themCLOSED - CURRENTRELEASEamacdona@redhat.com

Actions
Actions #1

Updated by amacdona@redhat.com almost 5 years ago

  • Copied to Story #3403: As a user I can add Manifests to a repository, and all units (recursive) that are part of them added
Actions #2

Updated by bmbouter over 3 years ago

  • Tags deleted (Pulp 3)
Actions #3

Updated by ipanova@redhat.com over 3 years ago

  • Copied to deleted (Story #3403: As a user I can add Manifests to a repository, and all units (recursive) that are part of them)
Actions #4

Updated by ipanova@redhat.com over 3 years ago

  • Is duplicate of Story #3403: As a user I can add Manifests to a repository, and all units (recursive) that are part of them added
Actions #5

Updated by ipanova@redhat.com over 3 years ago

  • Status changed from NEW to CLOSED - DUPLICATE
Actions #6

Updated by ipanova@redhat.com about 3 years ago

  • Project changed from Docker Support to Container Support

Also available in: Atom PDF