Project

Profile

Help

Issue #3392

Document Autodistribution

Added by kersom almost 3 years ago. Updated almost 2 years ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Documentation
Sprint:
Quarter:

Description

Publisher and Repository fields are not required fields for a standard distribution.

If both are provided, this distribution will automatically update to the newest publication every time the specified publisher publishes the specified repository.

This issue is to make this clear in the documentation (by fixing in-code comments) https://github.com/pulp/pulp/blob/3.0-dev/pulpcore/pulpcore/app/models/publication.py#L180-L183


Related issues

Related to Pulp - Task #3394: Validate that repository AND publisher must both be EITHER set or unset on a distributionCLOSED - CURRENTRELEASE

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>
Is duplicate of Pulp - Story #4680: As a user I have lifecycle docs in pulpcore workflowsCLOSED - CURRENTRELEASE

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by amacdona@redhat.com almost 3 years ago

  • Subject changed from Redudant fields for distribution model to Clarify publisher and repository fields on distribution model
  • Description updated (diff)

#2 Updated by amacdona@redhat.com almost 3 years ago

  • Description updated (diff)
  • Tags Documentation added

#3 Updated by amacdona@redhat.com almost 3 years ago

  • Related to Task #3394: Validate that repository AND publisher must both be EITHER set or unset on a distribution added

#4 Updated by dalley almost 3 years ago

  • Triaged changed from No to Yes

#5 Updated by daviddavis almost 3 years ago

It might be also worth considering renaming the fields (e.g. auto_distro_publisher, auto_distro_repository).

#6 Updated by kersom over 2 years ago

These fields will be used to auto-distribute feature. Currently there is no mention to such feature in the docs.

#7 Updated by amacdona@redhat.com about 2 years ago

  • Subject changed from Clarify publisher and repository fields on distribution model to Document Autodistribution

IMO this is clear in the help text on the distribution serializer. Still, the auto-distribution feature should be documented outside of the API docs, maybe in "Workflows"

#8 Updated by amacdona@redhat.com almost 2 years ago

  • Is duplicate of Story #4680: As a user I have lifecycle docs in pulpcore workflows added

#9 Updated by amacdona@redhat.com almost 2 years ago

  • Status changed from NEW to CLOSED - DUPLICATE

Autodistribution will be be covered by https://pulp.plan.io/issues/4680, so closing as a dupe.

#10 Updated by daviddavis almost 2 years ago

  • Sprint/Milestone set to 3.0.0

#11 Updated by bmbouter almost 2 years ago

  • Tags deleted (Pulp 3)

Please register to edit this issue

Also available in: Atom PDF