Project

Profile

Help

Issue #322

_href is wrong in consumer profile response body

Added by ipanova@redhat.com over 5 years ago. Updated 4 months ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Category:
-
Start date:
Due date:
Estimated time:
Severity:
1. Low
Version:
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

$ curl -i -H "Accept: application/json" -H "WebFrameworkSwitch: webpy" -X POST -k -u admin:admin -d '{"content_type":"rpm", "profile":[]}' "https://localhost/pulp/api/v2/consumers/c1/profiles/"
HTTP/1.1 201 Created
Date: Thu, 26 Feb 2015 12:03:18 GMT
Server: Apache/2.4.10 (Fedora) OpenSSL/1.0.1e-fips mod_wsgi/3.5 Python/2.7.5
Location: /pulp/api/v2/consumers/c1/profiles/c1/rpm/
Content-Length: 310
Content-Type: application/json

{"profile": [], "_href": "/pulp/api/v2/consumers/c1/profiles/c1/rpm/", "_ns": "consumer_unit_profiles", "profile_hash": "4f53cda18c2baa0c0354bb5f9a3ecbe5ed12ab4d8e11ba873c2f11161202b945", "consumer_id": "c1", "content_type": "rpm", "_id": {"$oid": "54ef050845ef48674c3f5f50"}, "id": "54ef050845ef48674c3f5f50"}


Related issues

Is duplicate of Pulp - Issue #466: Wrong _href in the response body of consumer profile creationCLOSED - CURRENTRELEASE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by ipanova@redhat.com over 5 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to ipanova@redhat.com

#2 Updated by ipanova@redhat.com over 5 years ago

  • Status changed from ASSIGNED to 7
  • Parent task set to #466

#3 Updated by bmbouter over 5 years ago

  • Triaged changed from No to Yes
  • Severity set to Low

#4 Updated by bmbouter over 5 years ago

  • Status changed from 7 to CLOSED - DUPLICATE

#5 Updated by bmbouter over 5 years ago

  • Parent task deleted (#466)

#6 Updated by bmbouter over 5 years ago

  • Is duplicate of Issue #466: Wrong _href in the response body of consumer profile creation added

#7 Updated by bmbouter over 5 years ago

  • Severity changed from Low to 1. Low

#8 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

#9 Updated by bmbouter 4 months ago

  • Category deleted (14)

We are removing the 'API' category per open floor discussion June 16, 2020.

Please register to edit this issue

Also available in: Atom PDF