Project

Profile

Help

Issue #3161

Centos 7 debuginfo x86_64 | Malformed repository: metadata is missing for some packages in filelists.xml and in other.xml

Added by qha about 2 years ago. Updated 11 months ago.

Status:
CLOSED - WONTFIX
Priority:
Normal
Assignee:
-
Category:
pulp-admin
Sprint/Milestone:
-
Start date:
Due date:
Severity:
2. Medium
Version:
Platform Release:
Blocks Release:
OS:
CentOS 7
Backwards Incompatible:
No
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
QA Contact:
Complexity:
Smash Test:
Verified:
No
Verification Required:
No
Sprint:

Description

When asked to sync http://debuginfo.centos.org/7/x86_64/ Pulp complains about "Malformed repository: metadata is missing for some packages in filelists.xml and in other.xml" yet yum will happily install packages from it.

I have created a static mirror of that repo (

with wget --mirror --no-parent --level 3 --accept .rpm,repodata,.xml,.xml.gz,.sqlite.bz2 --domains debuginfo.centos.org --directory-prefix /var/www/html/staticmirror http://debuginfo.centos.org/7/x86_64/

) at http://fiction.it.liu.se/debuginfo.centos.org/7/x86_64/ and Pulp makes the same compaints when trying to sync that repo and yum will install packages from there as well.

% pulp-admin rpm repo list --detail --repo-id centos-7-x86_64-base-debuginfo
+----------------------------------------------------------------------+
                            RPM Repositories
+----------------------------------------------------------------------+

Id:                   centos-7-x86_64-base-debuginfo
Display Name:         None
Description:          None
Content Unit Counts:  
Notes:                
Scratchpad:           
  Checksum Type: sha1
Importers:            
  Config:               
    Feed: http://fiction.it.liu.se/debuginfo.centos.org/7/x86_64/
  Id:                   yum_importer
  Importer Type Id:     yum_importer
  Last Override Config: 
  Last Sync:            2017-12-01T06:56:12Z
  Last Updated:         2017-11-29T16:19:51Z
  Repo Id:              centos-7-x86_64-base-debuginfo
  Scratchpad:           None
Distributors:         
  Auto Publish:         True
  Config:               
    Generate Sqlite: True
    Http:            False
    Https:           True
    Relative URL:    centos/7/base-debuginfo/x86_64/
  Distributor Type Id:  yum_distributor
  Id:                   yum_distributor
  Last Override Config: 
  Last Publish:         None
  Last Updated:         2017-11-23T12:17:33Z
  Repo Id:              centos-7-x86_64-base-debuginfo
  Scratchpad:           
  Auto Publish:         False
  Config:               
    Generate Sqlite: True
    Http:            False
    Https:           True
    Relative URL:    centos/7/base-debuginfo/x86_64/
  Distributor Type Id:  export_distributor
  Id:                   export_distributor
  Last Override Config: 
  Last Publish:         None
  Last Updated:         2017-11-23T12:17:33Z
  Repo Id:              centos-7-x86_64-base-debuginfo
  Scratchpad:           
% pulp-admin rpm repo sync run --repo-id centos-7-x86_64-base-debuginfo      
+----------------------------------------------------------------------+
       Synchronizing Repository [centos-7-x86_64-base-debuginfo]
+----------------------------------------------------------------------+

This command may be exited via ctrl+c without affecting the request.

Downloading metadata...
[|]
... completed

Downloading repository content...
[-]
... failed

Task Failed

Malformed repository: metadata is missing for some packages in filelists.xml and
in other.xml

% yum info pulp-admin-client
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
Installed Packages
Name        : pulp-admin-client
Arch        : noarch
Version     : 2.14.3
Release     : 1.el7
Size        : 195 k
Repo        : installed
From repo   : pulp-2-stable
Summary     : Admin tool to administer the pulp server
URL         : http://pulpproject.org/
License     : GPLv2
Description : A tool used to administer the pulp server, such as repo creation
            : and synching, and to kick off remote actions on consumers.

% yum info python-pulp-common
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
Installed Packages
Name        : python-pulp-common
Arch        : noarch
Version     : 2.14.3
Release     : 1.el7
Size        : 250 k
Repo        : installed
From repo   : pulp-2-stable
Summary     : Pulp common python packages
URL         : http://pulpproject.org/
License     : GPLv2
Description : A collection of components that are common between the pulp server
            : and client.

History

#1 Updated by dalley about 2 years ago

  • Triaged changed from No to Yes

#2 Updated by ttereshc about 2 years ago

The problem is in the following packages metadata (which is duplicated):

  <name>firefox-debuginfo</name>  <arch>x86_64</arch>  <version epoch="0" ver="45.1.1" rel="1.el7.centos"/>
  <name>firefox-debuginfo</name>  <arch>x86_64</arch>  <version epoch="0" ver="45.1.1" rel="1el7.centos"/>

Release field is technically the same due to the serialization algorithm which RPM uses.
Centos issue should be filed.

#3 Updated by qha about 2 years ago

Thank you for your analysis!

Does that fall on me or will you file an issue with Centos?

Best regards
/Ulrik Haugen
Linköping university

Pulp <> wrote:

#4 Updated by qha about 2 years ago

#5 Updated by ttereshc about 2 years ago

@qha, thanks for opening Centos issue!

#6 Updated by bmbouter 11 months ago

  • Status changed from NEW to CLOSED - WONTFIX

Pulp 2 is approaching maintenance mode, and this Pulp 2 ticket is not being actively worked on. As such, it is being closed as WONTFIX. Pulp 2 is still accepting contributions though, so if you want to contribute a fix for this ticket, please reopen or comment on it. If you don't have permissions to reopen this ticket, or you want to discuss an issue, please reach out via the developer mailing list.

#7 Updated by bmbouter 11 months ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF