Project

Profile

Help

Issue #3027

Pulp doesn't generate prestodelta.xml

Added by lenny about 4 years ago. Updated over 2 years ago.

Status:
CLOSED - WONTFIX
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
1. Low
Version:
2.13.0
Platform Release:
OS:
CentOS 7
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Hi guys,

let me know how I can help you to find a solution for this.

Kind regards,

Rene

Rene,

please open an issue ticket https://pulp.plan.io/issues/new .

This is a not regular behaviour.  I did a quick test on my pulp installation and was not able to observe same issue as you have.

We might need to investigate more on this, so descriptive bug report would be highly appreciated,

Thanks!

--------
Regards,

Ina Panova
Software Engineer| Pulp| Red Hat Inc.
pulp-admin rpm repo list --details --repo-id testing
Content Unit Counts:  
  Drpm: 12
  Rpm:  224
pulp-admin rpm repo publish run --force-full --repo-id testing

+-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------+

                                                                    Publishing Repository [testing]

+-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------+

The following publish configuration options will be used:

Force Full:  True

This command may be exited via ctrl+c without affecting the request.

Initializing repo metadata

[-]

... completed

Publishing Distribution files

[-]

... completed

Publishing RPMs

[=======================================================================================================================================] 100%

224 of 224 items

... completed

Publishing Delta RPMs

[=======================================================================================================================================] 100%

12 of 12 items

... completed

Publishing Errata

[-]

... completed

Publishing Comps file

[-]

... completed

Publishing Metadata.

[-]

... completed

Closing repo metadata

[-]

... completed

Generating sqlite files

[\]

... completed

Generating HTML files

[-]

... completed

Publishing files to web

[-]

... completed

Writing Listings File

[-]

... completed

Task Succeeded
pwd
/var/lib/pulp/published/yum/master/yum_distributor/testing
ls 1505830494.26/repodata/

40e9fbe54edbc6f9619310a8b80698cc51f96f95d1ec781477071f0195eb9b00-other.xml.gz        b84bf5f4dea698bf279b51487b01775396a8ed60124aff26c77d208c26e35b47-filelists.xml.gz

9b12c17f419932e740c55156cde2a35a246c7075a2f98605d288f22ac341bb89-primary.sqlite.bz2  c00913cbd12080fd8c656af9a0cee941e340a44970d53c5c432ab0e87e8f1a07-filelists.sqlite.bz2

9f7e68e69d7e2453caa3865a97f8165c1f34d089010c8eb00e7fef6396a6aafa-comps.xml.gz        c0fd9ed7ec4b6f5f95fe22abb80b9b0c6ac95bce172b79168d9898b7042ac866-updateinfo.xml.gz

a27718cc28ec6d71432e0ef3e6da544b7f9d93f6bb7d0a55aacd592d03144b70-comps.xml           d3214a780e6137d06d7a005c7b786c69ccc9ba83a372eefe794b1eeba3018b8f-other.sqlite.bz2

ae23bc5aecacc9203b291620c3ad472fc5ad795da09f762542620ccb78fee160-primary.xml.gz      repomd.xml

History

#1 Updated by ipanova@redhat.com about 4 years ago

since we were not able to reproduce this issue, some additional information would help us to debug: what is the external feed you are using to sync from?

#2 Updated by ipanova@redhat.com about 4 years ago

  • Project changed from Pulp to RPM Support
  • Category changed from 15 to 22
  • Version changed from 2.14.0 to 2.13.0

#3 Updated by lenny about 4 years ago

The packages in this repository where uploaded by using the pulp-admin client.

#4 Updated by ipanova@redhat.com about 4 years ago

$ pulp-admin rpm repo uploads drpm --repo-id myrepo --file ./yum-normal.drpm
Warning: path should have mode 0700 because it may contain sensitive information: /home/ipanova/.pulp/

+----------------------------------------------------------------------+
                              Unit Upload
+----------------------------------------------------------------------+

Extracting necessary metadata for each request...
[==================================================] 100%
Analyzing: yum-normal.drpm
... completed

Creating upload requests on the server...
[==================================================] 100%
Initializing: yum-normal.drpm
... completed

Starting upload of selected units. If this process is stopped through ctrl+c,
the uploads will be paused and may be resumed later using the resume command or
canceled entirely using the cancel command.

Uploading: yum-normal.drpm
[==================================================] 100%
63689/63689 bytes
... completed

Importing into the repository...
This command may be exited via ctrl+c without affecting the request.

[\]
Running...

Task Succeeded

Deleting the upload request...
... completed

$ pulp-admin rpm repo publish run --repo-id myrepo
Warning: path should have mode 0700 because it may contain sensitive information: /home/ipanova/.pulp/

+----------------------------------------------------------------------+
                     Publishing Repository [myrepo]
+----------------------------------------------------------------------+

This command may be exited via ctrl+c without affecting the request.

Initializing repo metadata
[-]
... completed

Publishing Distribution files
[-]
... completed

Publishing RPMs
[-]
... completed

Publishing Delta RPMs
[-]
... completed

Publishing Errata
[-]
... completed

Publishing Comps file
[-]
... completed

Publishing Metadata.
[-]
... completed

Closing repo metadata
[-]
... completed

Generating sqlite files
... skipped

Removing old repodata
[-]
... completed

Generating HTML files
... skipped

Publishing files to web
[-]
... completed

Writing Listings File
[-]
... completed

Task Succeeded

# ll /var/lib/pulp/published/yum/master/yum_distributor/myrepo/1506435194.44/repodata/
total 28
-rw-r--r--. 1 apache apache  140 Sep 26 16:13 090f2ce61b5a57b11cce8a76c36d56397168ed50c4f5ee431479d8e2c30e3e6a-other.xml.gz
-rw-r--r--. 1 apache apache   92 Sep 26 16:13 15091dcbeb82744b9832c8555f1fcb8b5cbef93e5b63f8514dcc7d378c3b0bd3-updateinfo.xml.gz
-rw-r--r--. 1 apache apache  422 Sep 26 16:13 7e24796d2fde466ce6069d7dcaa3b057b715622333ba9f36bb6ffb13df53d151-prestodelta.xml.gz
-rw-r--r--. 1 apache apache  124 Sep 26 16:13 a27718cc28ec6d71432e0ef3e6da544b7f9d93f6bb7d0a55aacd592d03144b70-comps.xml
-rw-r--r--. 1 apache apache  151 Sep 26 16:13 ccf2fa9192fe18e50d39ecee8464281745704cfc3023e6524c70f2a5eb27f499-primary.xml.gz
-rw-r--r--. 1 apache apache  145 Sep 26 16:13 f1884461f302bbd1504f6f3c10c05702a6786c2872985a5b6045b05c087108d0-filelists.xml.gz
-rw-r--r--. 1 apache apache 2570 Sep 26 16:13 repomd.xml

#5 Updated by ipanova@redhat.com about 4 years ago

so i managed to reproduce this in case the sqlite generation is enabled then prestodelta is not generated.

# ll /var/lib/pulp/published/yum/master/yum_distributor/myrepo/1506437579.24/repodata/
total 28
-rw-r--r--. 1 apache apache  134 Sep 26 16:52 1cb61ea996355add02b1426ed4c1780ea75ce0c04c5d1107c025c3fbd7d8bcae-primary.xml.gz
-rw-r--r--. 1 apache apache  609 Sep 26 16:52 1d2fe8f438878641a36d709be44d59ca9c5364f5629bf4863bb58a01c7b83ef2-filelists.sqlite.bz2
-rw-r--r--. 1 apache apache 1344 Sep 26 16:52 3b0c2c99a0d870dc59fa4c9785fab06b2311ecc9a78ae7885e2c9dbe73d0f5c9-primary.sqlite.bz2
-rw-r--r--. 1 apache apache  123 Sep 26 16:52 95a4415d859d7120efb6b3cf964c07bebbff9a5275ca673e6e74a97bcbfb2a5f-filelists.xml.gz
-rw-r--r--. 1 apache apache  585 Sep 26 16:52 d23a06304510a377f57d2986725b37dbba2e22e3da11d1cfa161d3047532f0ca-other.sqlite.bz2
-rw-r--r--. 1 apache apache  123 Sep 26 16:52 ef3e20691954c3d1318ec3071a982da339f4ed76967ded668b795c9e070aaab6-other.xml.gz
-rw-r--r--. 1 apache apache 3068 Sep 26 16:52 repomd.xml

#6 Updated by lenny about 4 years ago

wrote:

so i managed to reproduce this in case the sqlite generation is enabled then prestodelta is not generated.

[...]

Confirmed, I've disabled the sqlite/repoview flag and everything is fine. Thanks for the workaround Ina! :-)

#7 Updated by amacdona@redhat.com about 4 years ago

  • Severity changed from 2. Medium to 1. Low
  • Triaged changed from No to Yes

#8 Updated by bmbouter over 2 years ago

  • Status changed from NEW to CLOSED - WONTFIX

Pulp 2 is approaching maintenance mode, and this Pulp 2 ticket is not being actively worked on. As such, it is being closed as WONTFIX. Pulp 2 is still accepting contributions though, so if you want to contribute a fix for this ticket, please reopen or comment on it. If you don't have permissions to reopen this ticket, or you want to discuss an issue, please reach out via the developer mailing list.

#9 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF