Project

Profile

Help

Task #2896

Decide on Django version requirement before Pulp 3.0 RC

Added by ttereshc over 2 years ago. Updated 6 months ago.

Status:
CLOSED - COMPLETE
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
Start date:
Due date:
% Done:

0%

Platform Release:
Blocks Release:
Backwards Incompatible:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Release Engineering
QA Contact:
Complexity:
Smash Test:
Verified:
No
Verification Required:
No
Sprint:

Description

Currently Pulp 3.0 is compatible with Django>=1.8.
The initial idea was to release Pulp 3.0 with the latest Django LTS release available which will be 1.11, this is also the latest release in 1.x line.
At the same time Django 1.8 LTS will be supported until at least April 2018 so some users may still want to use this LTS release.

Pulp 3.0 is not expected to be included in Fedora 25 or 26 and also Django 1.11 is not available there at the moment.
Though we may want to distribute Pulp 3.0 on our own for Fedora 25 or 26 and in case of Django 1.11 requirement, python-django package should be distributed by us as well.
As for the supported RHEL distributions, only Django 1.11 will be available in SCL.

The task here is to decide closer to Pulp 3.0 RC release whether to require Django 1.11 right away or drop Django 1.8 support later in case Pulp 3.0 will still be compatible with Django 1.8 by that time.


Checklist


Related issues

Related to Packaging - Task #3533: Prepare for pypi pulp3 beta release MODIFIED Actions

History

#1 Updated by amacdona@redhat.com over 2 years ago

  • Tags Pulp 3 Plugin Writer Alpha added

#2 Updated by amacdona@redhat.com over 2 years ago

  • Tags deleted (Pulp 3 Plugin Writer Alpha)

#3 Updated by ttereshc over 2 years ago

  • Tags Release Engineering added

#4 Updated by bizhang over 1 year ago

  • Related to Task #3533: Prepare for pypi pulp3 beta release added

#5 Updated by dalley over 1 year ago

  • Status changed from NEW to CLOSED - COMPLETE

Pulp 3 supports Django 1.11 and 2.0 with a minimum required version of 1.11. 1.8 is no longer supported upstream nor in Pulp.

#6 Updated by daviddavis 6 months ago

  • Sprint/Milestone set to 3.0

#7 Updated by bmbouter 6 months ago

  • Tags deleted (Pulp 3)

Please register to edit this issue

Also available in: Atom PDF