Project

Profile

Help

Issue #2875

Removing agents / consumers gets stuck

Added by dustball over 4 years ago. Updated almost 3 years ago.

Status:
CLOSED - WONTFIX
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
1. Low
Version:
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

We've set up a pulp server in our organization. At some point I realized there are consumers in there, which souldn't be, because we don't want to use them at all. I've asked a coworker who did the initial setup where they come from and he has no clue either. However, removing them doesn't work, they just stick around in tasks (for a few days now):

+----------------------------------------------------------------------+
                                 Tasks
+----------------------------------------------------------------------+

Operations:  agent_unbind
Resources:   genka3 (consumer), centos-7-epel-x86_64 (repository),
             yum_distributor (repository_distributor)
State:       Waiting
Start Time:  Unstarted
Finish Time: Incomplete
Task Id:     34d74915-bb7c-4334-9272-eba8c2484648

Operations:  agent_unbind
Resources:   genka (consumer), centos-7-epel-x86_64 (repository),
             yum_distributor (repository_distributor)
State:       Waiting
Start Time:  Unstarted
Finish Time: Incomplete
Task Id:     a5a013e3-1f2d-4887-81e4-4602bfd9a2ad

Operations:  agent_unbind
Resources:   genka3 (consumer), centos-7-x86_64-base (repository),
             yum_distributor (repository_distributor)
State:       Waiting
Start Time:  Unstarted
Finish Time: Incomplete
Task Id:     fc07554f-4a2c-4af2-8095-e5d438172f7e

Canceling the tasks doesn't do anything either:

The following resource(s) could not be found:

  genka (consumer)

While this doesn't seem to affect functionality, I still would like to have them removed in case someone else has to manage pulp and stumbles over this.

History

#1 Updated by bmbouter over 4 years ago

You're the third unique user to tell me about this bug. You're the first to actually file it though. The key to reproducing this is something like:

1) add a consumer
2) ensure that consumer is not connected to the network (for example stop goferd on that consumer)
3) dispatch some tasks which will stay in the waiting state because the consumer is not online due to step (2)
4) delete the consumer
5) Try to cancel those tasks created with step (3)
6) observe that you cannot cancel them due to the consumer having been deleted.

The workaround is to add the consumer back, cancel all the tasks, then delete the consumer again.

#2 Updated by ttereshc over 4 years ago

  • Severity changed from 2. Medium to 1. Low
  • Triaged changed from No to Yes

#3 Updated by bmbouter almost 3 years ago

  • Status changed from NEW to CLOSED - WONTFIX

#4 Updated by bmbouter almost 3 years ago

Pulp 2 is approaching maintenance mode, and this Pulp 2 ticket is not being actively worked on. As such, it is being closed as WONTFIX. Pulp 2 is still accepting contributions though, so if you want to contribute a fix for this ticket, please reopen or comment on it. If you don't have permissions to reopen this ticket, or you want to discuss an issue, please reach out via the developer mailing list.

#5 Updated by bmbouter almost 3 years ago

  • Tags Pulp 2 added

Also available in: Atom PDF