Project

Profile

Help

Issue #2774

Inconsistent Checksum and Checksumtype when uploading with --checksum-type

Added by yuzheng over 2 years ago. Updated 9 months ago.

Status:
CLOSED - WONTFIX
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Severity:
2. Medium
Version:
Platform Release:
Blocks Release:
OS:
Backwards Incompatible:
No
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
QA Contact:
Complexity:
Smash Test:
Verified:
No
Verification Required:
No
Sprint:

Description

# rpm -qa pulp-server
pulp-server-2.13.0-1.el7.noarch

Reproducing steps:
1. Create a rpm repo

# pulp-admin rpm repo create --repo-id test-repo10
Successfully created repository [test-repo10]

2. Upload a drpm to the repo with --checksum-type=md5

# pulp-admin rpm repo uploads drpm --repo-id test-repo10 --file /root/test-alpha-1.1-2_1.1-3.noarch.drpm --checksum-type md5
+----------------------------------------------------------------------+
                              Unit Upload
+----------------------------------------------------------------------+

Extracting necessary metadata for each request...
[==================================================] 100%
Analyzing: test-alpha-1.1-2_1.1-3.noarch.drpm
... completed

Creating upload requests on the server...
[==================================================] 100%
Initializing: test-alpha-1.1-2_1.1-3.noarch.drpm
... completed

Starting upload of selected units. If this process is stopped through ctrl+c,
the uploads will be paused and may be resumed later using the resume command or
canceled entirely using the cancel command.

Uploading: test-alpha-1.1-2_1.1-3.noarch.drpm
[==================================================] 100%
3304/3304 bytes
... completed

Importing into the repository...
This command may be exited via ctrl+c without affecting the request.

[\]
Running...

Task Succeeded

Deleting the upload request...
... completed

3. Check uploaded drpm

# pulp-admin rpm repo content drpm --repo-id test-repo10
Arch:         noarch
Checksum:     f9476caa0f491dfa227a984b092e05f68b637471f7c7c2f648475f067f12fc2e
Checksumtype: md5
Epoch:        0
Filename:     drpms/test-alpha-1.1-2_1.1-3.noarch.drpm
Release:      3
Version:      1.1

Checksumtype is md5, but Checksum shows a value of sha256 checksum.

# sha256sum /root/test-alpha-1.1-2_1.1-3.noarch.drpm
f9476caa0f491dfa227a984b092e05f68b637471f7c7c2f648475f067f12fc2e  /root/test-alpha-1.1-2_1.1-3.noarch.drpm


Related issues

Related to RPM Support - Issue #2871: Old references to checksum_type need to be updated to checksumtype CLOSED - WONTFIX Actions

History

#1 Updated by bmbouter over 2 years ago

  • Tags RCM added

@yuzheng I'm adding the RCM flag since I think this is tracking something of interest to RCM. Consider setting it for any issues you file for RCM.

#6 Updated by ttereshc over 2 years ago

  • Triaged changed from No to Yes

#7 Updated by pthomas@redhat.com over 2 years ago

  • Smash Test set to 663

#8 Updated by kdelee@redhat.com over 2 years ago

  • Related to Issue #2871: Old references to checksum_type need to be updated to checksumtype added

#9 Updated by bmbouter 9 months ago

  • Status changed from NEW to CLOSED - WONTFIX

Pulp 2 is approaching maintenance mode, and this Pulp 2 ticket is not being actively worked on. As such, it is being closed as WONTFIX. Pulp 2 is still accepting contributions though, so if you want to contribute a fix for this ticket, please reopen or comment on it. If you don't have permissions to reopen this ticket, or you want to discuss an issue, please reach out via the developer mailing list.

#10 Updated by bmbouter 9 months ago

  • Tags Pulp 2 added

#11 Updated by bmbouter 9 months ago

  • Tags deleted (RCM)

Please register to edit this issue

Also available in: Atom PDF