Project

Profile

Help

Issue #2499

'Last Unit Added' attribute not updated

Added by adam.winberg@smhi.se almost 4 years ago. Updated over 1 year ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
2.11.0
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

I have a number of 'frozen' repos which I copy rpm's to weekly by script. To check when the repo was last updated with any content, I've been checking the 'Last Unit Added' attribute for the repo with the command:

$ pulp-admin rpm repo search --str-eq "id=<reponame>"

After updating to pulp 2.9.2 (from 2.7.0) this field is no longer updated. I've now also updated to 2.11 but the problem persists.

I also have several repos that are synced from external sources nightly, and the 'Last unit added' field is not updated on these either.

Is this a bug or am I doing something wrong?
When is this field supposed to get updated?
What is the correct way to determine when (date/time) a specific repo was last updated with new content?


Related issues

Is duplicate of Pulp - Issue #1847: last_unit_added is not added in mongo repo collection recordsCLOSED - CURRENTRELEASE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by ttereshc over 3 years ago

This is a bug, please find details and workaround here https://pulp.plan.io/issues/1847#note-3 while we are fixing it. Thanks!

#2 Updated by ttereshc over 3 years ago

  • Status changed from NEW to CLOSED - DUPLICATE

#3 Updated by ttereshc over 3 years ago

  • Is duplicate of Issue #1847: last_unit_added is not added in mongo repo collection records added

#4 Updated by bizhang over 3 years ago

  • Triaged changed from No to Yes

#5 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF